Bug 491399 - X random lockups, crashes, with radeon (r300) + firefox + gmail
X random lockups, crashes, with radeon (r300) + firefox + gmail
Status: CLOSED DUPLICATE of bug 436632
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 14:57 EDT by Paul
Modified: 2009-09-29 10:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-29 10:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Requested X log file (50.18 KB, text/plain)
2009-03-31 13:58 EDT, Andres Escallon
no flags Details
Previuos X log file (53.72 KB, text/plain)
2009-03-31 14:00 EDT, Andres Escallon
no flags Details
xorg.conf (1.22 KB, text/plain)
2009-04-01 01:18 EDT, Paul
no flags Details
Xorg.0.log (296.73 KB, text/plain)
2009-04-01 01:19 EDT, Paul
no flags Details

  None (edit)
Description Paul 2009-03-20 14:57:17 EDT
Description of problem:

Hard locks, which occur CONSISTENTLY within about 10 minutes of X server usage.  Prior to installing Xorg-server-1.5.3-15 I would only get hard locks when using compiz (see bug # 474052).  AFTER installing X server 1.5.3-15, I get hard locks even when using metacity.  Happens same in kde or gnome.  I have tested most recent fedora kernel (using 'nomodeset'), as well as most recent stable kernel.org kernel...same results.  (I never use kms)

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.5.3-15.fc10.i386
xorg-x11-drv-ati-6.10.0-2.fc10.i386

How reproducible:
VERY!

Steps to Reproduce:
1.  Boot up.
2.  Start X.
3.  Use X.
4.  In about 10 minutes PC will be bricked (hard lock, must hold power button in to reboot)
  
Actual results:
random hard locks


Expected results:
stability

Additional info:
Its a thinkpad T42.  additional info can be found in my previous bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=474052

Thanks.
Comment 1 Paul 2009-03-20 19:38:50 EDT
After further investigation, this nasty 2D bug only occurs when using firefox and vistiting GMAIL.  Sometimes it crashes instantly when i goto gmail, othertimes its not instant, but gmail is the common factor to every one of the crashes...and i'll estimate ive seen this crash at least 30 times in last week.

Using vesa driver, gmail works fine, and I cannot reproduce the crash at all.

So the bug must have been triggered by either firefox-3.0.7-1 or xorg-x11-server-common-1.5.3-15 both of which I installed a week or so ago, which is when this bug/crash started occurring.
Comment 2 Andres Escallon 2009-03-27 09:31:16 EDT
I have experienced the same bug.  It seems to be that the driver gets stuck on a loop.  I can access the system using ssh from other system and see that X takes about 65% of the CPU.  Firefox does it consistently It has happened with gimp, netbeans and others.  Most of the time the screen is scrolling.

kernel-2.6.27.19-170.2.35.fc10.i686.
xorg-x11-server-common-1.5.3-15.fc10.i386
xorg-x11-drv-ati-6.10.0-2.fc10.i386
Comment 3 Matěj Cepl 2009-03-31 12:26:49 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Andres Escallon 2009-03-31 13:58:47 EDT
Created attachment 337363 [details]
Requested X log file
Comment 5 Andres Escallon 2009-03-31 14:00:09 EDT
Created attachment 337364 [details]
Previuos X log file
Comment 6 Paul 2009-04-01 01:18:05 EDT
Created attachment 337439 [details]
xorg.conf

xorg.conf
Comment 7 Paul 2009-04-01 01:19:16 EDT
Created attachment 337440 [details]
Xorg.0.log
Comment 8 John Gilmore 2009-04-02 19:51:13 EDT
I too encountered a hard hang in X while using Firefox on a low end Radeon.  This hardware hasn't hung like this before "Radeon Test Day" (normally it runs Fedora Core 6).  I tried booting the test livecd (fedora-livecd--i686-201001041452).  The system comes up, has a few other much more minor problems, but within about 10 minutes, running Firefox, it produces this hard hang.  The cursor stops moving, there's no effect from ctl-alt-f1, ctl-alt-bs, ctl-alt-delete, or alt-tab.  Since it was a livecd with no user accounts, thus no option to ssh in remotely, I had to power cycle it.

Reproduced this hang twice.  Both times I was reading this page in Firefox:

  http://fcp.surfsite.org/modules/newbb/viewtopic.php?viewmode=flat&order=DESC&topic_id=68414&forum=12

and I had hit the scrollbar to try to scroll it to read more.  Bam, dead.
The second time I had "top" running in another window, and it hung and stopped updating its window too.  I had plenty of swap space available, that wasn't the cause of the hang.

This is with the ATI Radeon Express 200 5974 (NOT R300) on an HP dc5750.  I was unable to get dmesg output.  I had not messed with Xorg.conf as provided on that livecd.  I booted without changing any kernel options, and was just running the very first test (see if it boots and doesn't flicker the screen).

It hung a third time while I was browsing Google's privacy policy for Firefox.  In that case the symptoms were different:  the mouse would move, but nothing else happens.  Top stopped updating, couldn't click on anything, ctrl-alt-F1, alt-tab, c-a-del, c-a-bs all produce no effect.  I power cycled it.
Comment 9 David Rees 2009-04-02 21:05:53 EDT
I'd bet that turning off DRI (in the device section) fixes the hangs.

I've been experiencing similar hangs myself, and that's the only setting I can find that fixes things.  I also have to use nomodeset, otherwise it crashes much earlier.

http://bugs.freedesktop.org/show_bug.cgi?id=20348
Comment 10 David Rees 2009-09-17 03:04:47 EDT
I was reviewing the ati bugs I'm CC'd on here and thought this one looked like upstream #21598: http://bugs.freedesktop.org/show_bug.cgi?id=21598
Comment 11 Matthew Miller 2009-09-29 10:07:33 EDT

*** This bug has been marked as a duplicate of bug 436632 ***

Note You need to log in before you can comment on or make changes to this bug.