Bug 49141 - XFree86-4.1.0-0.8.6 not compile
Summary: XFree86-4.1.0-0.8.6 not compile
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-15 13:29 UTC by Vladimir Kondratiev
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-15 13:29:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vladimir Kondratiev 2001-07-15 13:29:01 UTC
Description of problem:
Package do not compile due to compiler flag '-fno-merge-constants'.
Failure occurred in directory xc/lib/font/bitmap, file bitmap.c
Flag mentioned is not found neither in gcc 2.96, nor in gcc 3.0


How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild XFree86-4.1.0-0.8.6.src.rpm
2.
3.
	

Actual Results:  gcc -O2 -march=i386 -mcpu=i686 -pipe -ansi -pedantic -Wall
-Wpointer-arith -fno-merge-constants  -I../../../../include/fonts
-I../../include -I../../../../programs/Xserver/include 		  
-I../../../../include -I../  -I../../../.. -I../../../../exports/include 
-Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE
-D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE  -D_GNU_SOURCE  -DSHAPE
-DXINPUT -DXKB -DLBX -DXAPPGROUP -DXCSECURITY -DTOGCUP  -DXF86BIGFONT
-DDPMSExtension  -DPIXPRIV -DPANORAMIX  -DRENDER -DGCCUSESGAS
-DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH -DXFreeXDGA -DXvExtension
-DXFree86LOADER  -DXFree86Server -DXF86VIDMODE  -DSMART_SCHEDULE
-DBUILDDEBUG -DX_BYTE_ORDER=X_LITTLE_ENDIAN -DNDEBUG  -DFUNCPROTO=15
-DNARROWPROTO  -DIN_MODULE -DXFree86Module -DFONTMODULE -DBDFFORMAT
-DSNFFORMAT -DPCFFORMAT   -c bitmap.c
cc1: Unrecognized option `-fno-merge-constants'

make[6]: *** [bitmap.o] Error 1



Expected Results:  compilation OK

Additional info:

Comment 1 Mike A. Harris 2001-07-15 14:48:47 UTC
You need to either:

1) Use gcc from rawhide

or

2) Edit the spec file and remove the changes that were done to work
   with gcc string merging, prelinking

#1 is recommended, unless this is for a production system, in which case
it is not recommended to use 4.1.0 yet anyway.

I've resolved this bug by making gcc >= 2.96-93 a buildprereq in the specfile.


Note You need to log in before you can comment on or make changes to this bug.