Bug 491413 - Left-click on window border acts like a right-click
Left-click on window border acts like a right-click
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 16:49 EDT by Josh Stone
Modified: 2014-06-18 05:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-21 14:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Stone 2009-03-20 16:49:49 EDT
Description of problem:
When the title bar of a window is hidden off the top of the screen, then it's hard to resize the window, because all clicks on the border act like right-clicks.

Version-Release number of selected component (if applicable):
metacity-2.24.0-2.fc10.x86_64
(BTW, I'm only guessing that this is a metacity problem, because it's not unique to any particular application AFAICS)

How reproducible:
very

Steps to Reproduce:
1. ALT-click-drag any window and move it up until the title bar is hidden.
2. Left-click on the left/right/bottom window border.
  
Actual results:
The right-click context menu appears upon the left-click.  A real right-click still brings up the context menu as well.

Expected results:
The border should start resizing when dragging.

Additional info:
Selecting resize from the context menu still works, so it is still possible to resize the window, just more cumbersome.

I've run into this on my netbook with a low resolution, where I sometimes have to ALT-drag windows around to see all their content.
Comment 1 Søren Sandmann Pedersen 2009-03-21 14:40:48 EDT
I basically agree with you, but you'll need to convince the metacity maintainer upstream about this; this is not something we'd change in Fedora.
Comment 2 Søren Sandmann Pedersen 2009-03-22 18:07:30 EDT
See http://bugzilla.gnome.org/show_bug.cgi?id=480270 .

Note You need to log in before you can comment on or make changes to this bug.