Bug 491422 - gpk-update-viewer2 is too big for netbooks
gpk-update-viewer2 is too big for netbooks
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 17:20 EDT by Josh Stone
Modified: 2010-05-27 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 12:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Stone 2009-03-20 17:20:31 EDT
Description of problem:
The new update window has a minimum size that's too big for netbook resolutions (1024x600).

First, it starts with a very small window that is centered on the screen.  After it does its initial processing, it grows down and right so that a lot of the window is off screen.

Then I tried to move the window into full visibility, but the height is too tall for my netbook resolution.  Most notably, this means that the action buttons at the bottom are not visible.

I can resize the window somewhat, but it has a minimum size that's still too big to see everything.  Also, maximizing the window does almost nothing (the window decoration loses the rounded edges, but the size and position doesn't change).

I can ALT-drag the window up to get access to the action buttons, but I think most users won't know how to do this...


Version-Release number of selected component (if applicable):
gnome-packagekit-0.4.5-3.fc11.i586
Comment 1 Josh Stone 2009-03-20 18:14:32 EDT
I just tried the latest on koji since rawhide is on its beta freeze:
gnome-packagekit-0.4.6-0.2.20090319git.fc11.i586

With this one the window is still initially too big, but the minimum size now allows me to resize it down to something usable.  It's still a little too big even then, but I can at least use the buttons.
Comment 2 Richard Hughes 2009-03-23 12:54:00 EDT
commit eefd675e27fca60da1250a0ceee8fac5d0ea0f43
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Mar 23 16:53:08 2009 +0000

    bugfix: set an initial size of the new update viewer using gpk_window_set_size_request() so we can do clever things when in SFF mode. Fixes rh#491422

Note You need to log in before you can comment on or make changes to this bug.