Bug 491445 - Wireshark does not include SMI support
Wireshark does not include SMI support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 21:27 EDT by John Tapparo
Modified: 2009-03-26 04:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 04:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Tapparo 2009-03-20 21:27:43 EDT
Description of problem:
Wireshark will not decode OIDs from SNMP MIBs.  This is due to the lack of inclusion of libsmi support.

The source RPM is set to configure --with-libsmi.

Version-Release number of selected component (if applicable):
  wireshark-1.0.6-1.fc10.x86_64
  wireshark-gnome-1.0.6-1.fc10.x86_64


How reproducible:
  Always

Steps to Reproduce:
1.  Launch Wireshark and go to Help/About
2.  Note the "without SMI"
3.  You could also try to decode some SNMP captures.
  
Actual results:
Wireshark is built without libsmi support:

From Help/About Wireshark:
Compiled with GTK+ 2.14.7, with GLib 2.18.4, with libpcap 0.9.8, with libz
1.2.3, without POSIX capabilities, with libpcre 7.8, without SMI, without ADNS,
without Lua, with GnuTLS 2.4.2, with Gcrypt 1.4.3, with MIT Kerberos, without
PortAudio, without AirPcap.


Expected results:
Whireshark is built with libsmi support.


Additional info:

I would like to see the feature included.

The source RPM's %configure includes a "--with-libsmi", however, according to the help/about in Wireshark, it is not there.  I suspect this is due to the build machine not having libsmi-devel installed.  This seems to be strictly a build problem.

I installed libsmi-devel on my machine and rebuilt the src rpm and SMI support is now included on my personal build.

If the intent is to not include this for some reason, that is fine.  However it looked to me like it was trying to be included.

This also seems to exist on the i386 build.
Comment 1 John Tapparo 2009-03-20 21:34:28 EDT
Oops... "This also seems to exist on the i386 build," would be more clear if it said "This bug also seems to exist on the i386 build."  Meaning that SMI support does not exist in the i386 wireshark RPM either.
Comment 2 Radek Vokal 2009-03-26 04:49:27 EDT
Ah, true .. missing build dependency on libsmi-devel. I'm going to fix this with next wireshark update. Right now it's fixed only in rawhide.

Note You need to log in before you can comment on or make changes to this bug.