Bug 491468 - guest miss its cdrom source definition node in the xml frequently
guest miss its cdrom source definition node in the xml frequently
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-21 09:18 EDT by Vivian Bian
Modified: 2016-04-26 11:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 13:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the fedora10.xml I'm using in RHEV (1.04 KB, text/plain)
2009-03-21 09:18 EDT, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2009-03-21 09:18:02 EDT
Created attachment 336161 [details]
the fedora10.xml I'm using in RHEV

Description of problem:
with a written xml file define a guest,and then start it,access the guest via vnc,get a Fatal error: fail to boot from CDROM.Back to the host,virsh dumpxml ,have found the <source file='/diretory/to/the/iso/file.iso'/> was missing under the <disk type='file' >

Version-Release number of selected component (if applicable):
ovirt-node-image-1.0-1.snap5.2.el5ovirt

How reproducible:
Frequently not always

Steps to Reproduce:
1.define a guest with the attached file # virsh define fedora10.xml
2.# virsh start fedora10
3.# vncviewer $HOSTIP:PORT
  
Actual results:
Fatal error: fail to boot,<source file='/diretory/to/the/iso/file.iso'/> was missing

Expected results:
the xml <source file> brunch will not be missed

Additional info:
Comment 1 Perry Myers 2009-03-30 23:21:55 EDT
Moving to RHEL since libvirt is not supported in RHEV1.0 production builds and this problem will need to be addressed in RHEL5.4 release
Comment 2 Daniel Veillard 2009-04-23 13:04:39 EDT
Hum, I have tried to reproduce the same problem using the same kind of
setting, except for the network configuration of the guest and when
trying for more than 6 times I always got the Welcome to Fedora 10 
prompt showing that the iso file was being loaded.

So I have no idea how to test this, I can't reproduce the problem myself.
Any idea ?

Daniel
Comment 3 Vivian Bian 2009-04-23 22:33:04 EDT
as it is not a 100% reproducible bug,I really can't point out a pretty idea for your request, but I want to check:
1.whether you used the libvirt-0.5.1-3.el5ovirt to check this issue?
2.and you could check with the dumpxml when you're running the guest,even when it could start well, then reboot it via #virsh destroy fedora10 and then #virsh start fedora10,replicate this more times.

Note You need to log in before you can comment on or make changes to this bug.