Bug 491472 - RFE Restore: abortable, selective, feedback
RFE Restore: abortable, selective, feedback
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fwbackups (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Stewart Adam
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-21 09:59 EDT by bruce
Modified: 2009-04-09 12:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.43.3-0.1.rc1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 12:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bruce 2009-03-21 09:59:35 EDT
Description of problem:
I think I'm going to like fwbackups, but there
are a couple of interface issues that make it
less comfortable than it could be, at least
for first uses:
 (1) When you start a restore from a Backup Set,
  there is an abort button (whatever it was called),
  but it is disabled (greyed).
  Killing the window, does not stop the restore.

 (2) When you then try to exit the "Administrator",
  it says operations are in progress, asks "Would you
  like to cancel them and quit anyways?".
  I say yes, but it neither cancels, nor closes.

 (3) It would be nice to be able to select specific files
  from the backup to be restored, rather than
  have to restore the entire (huge) set.
  [Perhaps if I had set the destination directory
   correctly, it would have noticed most files were
   the same and would have been faster....
   Of course, if I had been able to abort....]

 (4) Both restore and backup would be more reassuring
  if they showed what they were doing (eg. what
  files/directories they were working on).
  At least, when the gui is onscreen...

Version-Release number of selected component (if applicable):
1.43.2-3
Comment 1 Stewart Adam 2009-03-22 18:05:43 EDT
I'm working on #1, hopefully fixed in the next few days. #2 is a problem because of #1, once canceling is supported then it will close itself properly. #3/#4 are a bit more tough to do since fwbackups (at the moment) doesn't do the actual restoring, but rather wraps calls to rsync and tar. I'm in the works of writing a new C++ branch which will do the restoring and backing up internally, so it will be much faster and some features can be more tightly integrated but because of time limitations, I doubt it will be ready for another year or so.
Comment 2 Fedora Update System 2009-03-23 00:10:27 EDT
fwbackups-1.43.3-0.1.rc1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/fwbackups-1.43.3-0.1.rc1.fc9
Comment 3 Fedora Update System 2009-03-23 11:55:10 EDT
fwbackups-1.43.3-0.1.rc1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update fwbackups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2936
Comment 4 Fedora Update System 2009-03-23 12:00:22 EDT
fwbackups-1.43.3-0.1.rc1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fwbackups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2972
Comment 5 Fedora Update System 2009-04-09 12:08:19 EDT
fwbackups-1.43.3-0.1.rc1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-04-09 12:10:30 EDT
fwbackups-1.43.3-0.1.rc1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.