Bug 491481 - esound-libs i586 and x86_64 version cannot coexist
esound-libs i586 and x86_64 version cannot coexist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-21 12:48 EDT by Robert de Rooy
Modified: 2009-04-01 00:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 00:04:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert de Rooy 2009-03-21 12:48:59 EDT
Description of problem:
Trying to install wine on Fedora 11 Alpha with all updates applied tries to pull in esound-libs.i586, while esound-libs.x86_64 is already installed. This causes 2 errors. The x86_64 version is slightly newer and a config file conflict

Version-Release number of selected component (if applicable):
esound-libs-1:0.2.41-1.fc10.x86_64
esound-libs-1:0.2.40-2.fc11.i586

How reproducible:
try to install both x86_64 and i586 version of esound-libs

Steps to Reproduce:
1. Install Fedora 11
2. update with all available updates
3. try to install wine, which pulls in esound-libs.i586
  
Actual results:
Transaction Check Error:
  package esound-libs-1:0.2.41-1.fc10.x86_64 (which is newer than esound-libs-1:0.2.40-2.fc11.i586) is already installed
  file /etc/esd.conf from install of esound-libs-1:0.2.40-2.fc11.i586 conflicts with file from package esound-libs-1:0.2.41-1.fc10.x86_64

Expected results:


Additional info:
Comment 1 Robert de Rooy 2009-03-22 17:05:55 EDT
I noticed that 'package-cleanup --orphans' was listing esound-libs, and that the rawhide repository does have an fc11 x86_64 version that will not be installed since my fc10 version (which I got from a clean F11 alpha install) is newer.

So I downloaded the fc11 x86_64 version and did a force install. I also had to manually remove the fc10 version because after the force install I had both the fc10 and fc11 version in the RPM db.

after that the wine install succeeded.
Comment 2 Matthias Clasen 2009-03-30 00:08:24 EDT
Looking at the contents of /etc/esd.conf, I think we may want to patch esd_config.c to default esd_no_spawn to 1, and then nuke the config file.

Does that sound ok ?
Comment 3 Lennart Poettering 2009-03-30 10:24:39 EDT
Sounds good to me. But I am not sure this is any high priority. After all the only reason why esd is still in the archive is that I need something to test my stuff against.
Comment 4 Robert de Rooy 2009-03-30 13:48:58 EDT
Perhaps the wine package should not pull in wine-esd anymore, which in turn pulls in esound-libs. At least if I understand correctly that wine does not actually need ESD.

But yes, changing the defaults such that the config file is no longer required, seems like a good idea.
Comment 5 Matthias Clasen 2009-04-01 00:04:38 EDT
I've removed /etc/esd.conf in rawhide.

Note You need to log in before you can comment on or make changes to this bug.