Bug 491505 - Next LVM error
Next LVM error
Status: CLOSED DUPLICATE of bug 491746
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:995751f3e96015359...
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-22 05:34 EDT by A.J. Werkman
Modified: 2009-03-24 04:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 04:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (148.48 KB, text/plain)
2009-03-22 05:34 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2009-03-22 05:34:36 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 370, in lvcreate
    raise LVMError("lvcreate failed for %s/%s" % (vg_name, lv_name))
  File "/usr/lib/anaconda/storage/devices.py", line 1962, in create
    lvm.lvcreate(self.vg.name, self._name, self.size)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 206, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 660, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 184, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 697, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1026, in <module>
    anaconda.intf.run(anaconda)
LVMError: lvcreate failed for vg_bestel/lv_root
Comment 1 A.J. Werkman 2009-03-22 05:34:45 EDT
Created attachment 336193 [details]
Attached traceback automatically from anaconda.
Comment 2 A.J. Werkman 2009-03-22 06:24:15 EDT
I use a system with two fysical harddisks. This exception occures when I select both harddsiak for partitioning. When I select only the first disk I get mixed results. Sometimes the installation process succeeds sometimes I still get an exception error.
Comment 3 Joel Andres Granados 2009-03-23 14:48:42 EDT
In these cases the /tmp/program.log is more helpfull as its the one that has the lvm command output.  Can you pls provide that file?
Comment 4 A.J. Werkman 2009-03-23 16:23:46 EDT
Tried to reproduce, but got even another partitioning error.

This one is files under #491750

I will still try to reproduce this one.
Comment 5 A.J. Werkman 2009-03-23 17:28:28 EDT
It's in the traceback:

/tmp/program.log:
Running... ['udevadm', 'trigger', '--subsystem-match=block']
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['/usr/sbin/hwclock', '--hctosys', '-u']
Running... ['swapoff', '-a']
swapoff: /etc/fstab: No such file or directory
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle']
Running... ['mke2fs', '-t', 'ext3', '/dev/sda1']
Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
51200 inodes, 204800 blocks
10240 blocks (5.00%) reserved for the super user
First data block=1
Maximum filesystem blocks=67371008
25 block groups
8192 blocks per group, 8192 fragments per group
2048 inodes per group
Superblock backups stored on blocks: 
	8193, 24577, 40961, 57345, 73729

Writing inode tables:  0/25 1/25 2/25 3/25 4/25 5/25 6/25 7/25 8/25 9/2510/2511/2512/2513/2514/2515/2516/2517/2518/2519/2520/2521/2522/2523/2524/25done                            
Creating journal (4096 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 20 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle']
Running... ['lvm', 'pvcreate', '/dev/sda2']
  Physical volume "/dev/sda2" successfully created
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['udevadm', 'settle']
Running... ['lvm', 'pvcreate', '/dev/sdb1']
  Physical volume "/dev/sdb1" successfully created
Running... ['udevadm', 'settle']
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['lvm', 'vgcreate', '-s', '4M', 'vg_bestel', '/dev/sda2', '/dev/sdb1']
  Volume group "vg_bestel" successfully created
Running... ['udevadm', 'settle', '--timeout=10']
Running... ['lvm', 'lvcreate', '-L', '386760m', '-n', 'lv_root', 'vg_bestel']
  Insufficient free extents (48873) in volume group vg_bestel: 96690 required
Comment 6 David Lehman 2009-03-23 17:35:40 EDT
Joel, see bug 491746. I think they are the same.
Comment 7 Joel Andres Granados 2009-03-24 04:58:31 EDT
The messages from  bug 491746 are the same,  I'm duping this one.

*** This bug has been marked as a duplicate of bug 491746 ***

Note You need to log in before you can comment on or make changes to this bug.