Bug 491512 - After installation of Fedora 11 Alpha from DVD ISO image (i386), the system cannot boot
After installation of Fedora 11 Alpha from DVD ISO image (i386), the system c...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 08:53 EDT by Jorge Doutor
Modified: 2009-04-28 13:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 13:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorge Doutor 2009-03-22 08:53:07 EDT
Description of problem:
After installation of Fedora 11 Alpha from DVD ISO image (i386), the system cannot boot. After reading the physical volumes, and saying that 2 logical volume(s) are active, it stops with the message:
mount: could not find filesystem '/dev/root'

Version-Release number of selected component (if applicable):
Fedora 11 Alpha

How reproducible:
Installation of Fedora 11 Alpha from DVD ISO image (i386)

Steps to Reproduce:
1. Install from Fedora-11-Alpha-i386-DVD.iso
2. Reboot

  
Actual results:
The system does not complete the boot

Expected results:
Normal boot

Additional info:
The system is running inside VirtualBox xVM Sun v. 2.1.4
Fedora 8 and Fedora 10 both run without problems inside VirtualBox
Comment 1 Jorge Doutor 2009-03-22 10:56:02 EDT
After reading the comments at:

http://www.linuxquestions.org/questions/fedora-installation-39/fc6-mount-could-not-find-filesystem-devroot-497332/

I solved the problem, booting from the installation CD in rescue mode, changing the file grub.conf so that instead of:

kernel /boot/vmlinuz root=UUID=...

I entered:

kernel /boot/vmlinuz root=/dev/sda1

Now it boots, it shows the incremental bars on the bottom of the screen until they become fully white, and then it stops! At this stage I don't have access to a login screen.

But I think this is a different bug...
Comment 2 Chris Lumens 2009-03-23 10:08:11 EDT
The alpha was quite a long time ago and almost all of the storage code has changed since then.  Could you please try again when the beta live cd is released and let us know if you are still seeing this problem?  Thanks.
Comment 3 Jorge Doutor 2009-04-24 14:17:22 EDT
The beta solved the problem. Thanks.
Comment 4 Chris Lumens 2009-04-28 13:31:02 EDT
Thanks for retesting.

Note You need to log in before you can comment on or make changes to this bug.