Bug 491527 - Anaconda hangs at boot
Summary: Anaconda hangs at boot
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 11
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-22 16:57 UTC by Tom Diehl
Modified: 2010-06-28 11:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 11:32:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of machine when it hangs. (3.49 MB, image/jpeg)
2009-03-22 16:57 UTC, Tom Diehl
no flags Details
lower resolution screenshot of hang (155.62 KB, image/jpeg)
2009-03-25 03:18 UTC, Chuck Ebbert
no flags Details
/proc/cpuinfo for the system in question (482 bytes, text/plain)
2009-04-02 14:43 UTC, Tom Diehl
no flags Details
lspci -vv (8.75 KB, text/plain)
2009-04-02 14:45 UTC, Tom Diehl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 13002 None None None Never

Description Tom Diehl 2009-03-22 16:57:17 UTC
Created attachment 336204 [details]
Screen shot of machine when it hangs.

Description of problem: anaconda hangs at boot on inspiron 2650.


Version-Release number of selected component (if applicable): Latest rawhide as of 22 Mar 09


How reproducible: pxe boot the machine and watch it hang


Steps to Reproduce:
1. pxe boot the machine and watch the inital boot progress.
2. 

Actual results: Machine hangs


Expected results: machine boots normally


Additional info: screen shot attached

Comment 1 Chuck Ebbert 2009-03-25 03:18:08 UTC
Created attachment 336582 [details]
lower resolution screenshot of hang

Comment 2 Tom Diehl 2009-04-02 14:43:18 UTC
Created attachment 337827 [details]
/proc/cpuinfo for the system in question

The attachment is the output of /proc/cpuinfo. I was able to get rawhide working by installing F10 and doing a yum upgrade. Unfortunately, neither the i586 or the PAE kernel will boot. They still hang as shown in the previous screenshot. I tried it again this AM with the 2.6.29.1-37.rc1.fc11.{i586,PAE} kernels but it still hangs. I am currently using the 2.6.27.19-170.2.35.fc10.i686 to get the machine to boot.

The machine is an inspiron 2650 with 512Megs of memory in it. 

Is there some switch I can try booting with that might help troubleshoot this problem? I would really like to test fc11 but I am not able due to this problem.

Comment 3 Tom Diehl 2009-04-02 14:45:03 UTC
Created attachment 337828 [details]
lspci -vv

lspic -vv in case it is useful.

Comment 4 Tom Diehl 2009-04-11 17:12:22 UTC
I tried installing again with today's rawhide (11 Apr 2009) and no change. I then tried installing with acpi=off and the boot sequence gets further. During the boot I see the following errors:

/sbin/dbus-daemon: Error While Loading Shared Libraries: libAudit.so.0 Cannot open shared object file: No such file or directory

Couldn't connect to systemBus: failed to connect to socket /var/run/dbus/system_bus_socket: no such file or directory.

Then an ncurses box comes up and says There was an error configuring your network interface with a retry or cancel box. At that point I aborted the install.

I then booted the machine with the PAE kernel 2.6.29.1-54.fc11.i686.PAE and the acpi=off switch. The machine gets further in th eboot swquence but it hangs with the last line that says:

apm:Biosversion 1.2 flags 0x03 (driver version 1.16AC).

I then tried booting the  2.6.29.1-54.fc11.i586 with a acpi=off switch and the machine comes up and plays.

cat /proc/cpuinfo shows pae in the flags.

Is there any possibility anyone will look into this or am I wasting my time even filing this bug?

Is there a different switch I should be using instead of disabling acpi completely? F9 and F10 did not require this on this machine.

Comment 5 Bug Zapper 2009-06-09 12:29:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Patrick Barnes 2009-06-23 08:04:01 UTC
Just ran into this problem.  The following kernel parameters allowed the system to boot (using PAE build):

 acpi=off apm=off

I will do some further testing and report back if I can find anything.

Comment 7 Patrick Barnes 2009-06-23 08:25:31 UTC
This appears to be related:

http://bugzilla.kernel.org/show_bug.cgi?id=13002

https://bugs.launchpad.net/linux/+bug/327499

This kernel parameter did allow the notebook to boot:

 pci=noacpi

Comment 8 Patrick Barnes 2009-06-23 09:24:02 UTC
Using pci=noacpi seems to be the best workaround available.  The bug at kernel.org seems like a solid lead.  Hopefully, there will be a resolution before Fedora 12.


A separate issue, but potentially still of interest to anyone that hits this bug...

The graphical stage of the installation did not launch with the auto-detected video driver.  I added the following kernel parameter to work around the problem:

 xdriver=vesa

I did choose an upgrade to the video card when I originally purchased this notebook, so YMMV.

Comment 9 Bug Zapper 2010-04-27 13:17:27 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Bug Zapper 2010-06-28 11:32:17 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.