Bug 49154 - iptables-save saves rules without jump target incorrectly
iptables-save saves rules without jump target incorrectly
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: iptables (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-16 04:00 EDT by Florian Wisser
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 08:09:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Wisser 2001-07-16 04:00:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i686)

Description of problem:
iptable-restore is not able to restore rulesets written with
iptables-save if there is a rule without a jump target. (rules
to count traffic for example)

How reproducible:
Always

Steps to Reproduce:
1. iptables -I FORWARD 1
2. iptables-save > iptables
3. iptables-restore < iptables
	

Actual Results:  iptables-restore v1.2.2: Unknown arg `-j'
Try `iptables-restore -h' or 'iptables-restore --help' for more
information.


Additional info:

the problem is, that iptables-save writes the following line:
-A FORWARD -j  
instead of this one:
-A FORWARD
which actually works with iptables-restore.
Comment 1 Bernhard Rosenkraenzer 2001-07-16 07:00:32 EDT
Verified; problem still exists in the current version
Comment 2 Florian Wisser 2001-07-16 08:09:28 EDT
i just checked out that this bug is resolved in the cvs version of netfilter
Comment 3 Bernhard Rosenkraenzer 2001-07-16 09:20:32 EDT
Fix from CVS backported in 1.2.2-3

Note You need to log in before you can comment on or make changes to this bug.