Bug 491544 - SELinux is preventing python (hplip_t) "read" to ./hplip.state (var_lib_t).
SELinux is preventing python (hplip_t) "read" to ./hplip.state (var_lib_t).
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
3
i386 Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 16:48 EDT by rfc01
Modified: 2009-04-05 08:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-05 08:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Alert file from SELinux when trying to add a printer (2.79 KB, text/plain)
2009-03-22 16:48 EDT, rfc01
no flags Details

  None (edit)
Description rfc01 2009-03-22 16:48:38 EDT
Created attachment 336220 [details]
Alert file from SELinux when trying to add a printer

Description of problem:
See attached SELinux Alert file

Version-Release number of selected component (if applicable):


How reproducible:
Happens every time I try to add a printer.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2009-03-23 05:59:40 EDT
Which version of Fedora are you using?  What does 'rpm -q hplip' say?
Comment 2 rfc01 2009-04-04 09:55:09 EDT
I am using Fedora 10. And when I run "rpm -q hplip," the message I get states:

package hplip is not installed

which is confusing since the HP Device Manager shows under Applications/Accessories menu panel.

I installed hplip using a shell script file from the following website using a file named "hplip-3.9.2.run." It installed using yum.
Here is a link to the website:
http://hplipopensource.com/hplip-web/index.html
Comment 3 Tim Waugh 2009-04-05 08:06:29 EDT
Why didn't you install the hplip package that comes with Fedora?  We don't have any control over upstream hplip, only the version that we package with Fedora.

Note You need to log in before you can comment on or make changes to this bug.