This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 491575 - F9=>F10 preupgrade hangs at "Generating metadata 18%"
F9=>F10 preupgrade hangs at "Generating metadata 18%"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 01:07 EDT by Gerry Reno
Modified: 2014-01-21 18:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 15:30:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2009-03-23 01:07:13 EDT
Description of problem:
On a machine with a lot of packages (1139), trying to upgrade a fully-upgraded F9 installation to F10 using preupgrade.
It runs through without problem until it gets to "Prepare and test upgrade" section where it hangs every time at "Generating metadata 18%".

In the terminal window it shows Missing dependencies for:
xulrunner
pidgin
cups
vim-enhanced

There is 80GB of space available for install.  Says 500MB required.


Version-Release number of selected component (if applicable):
preupgrade-1.0.1-1.fc9

How reproducible:
always

Steps to Reproduce:
1. fully update an F9 installation
2. run preupgrade
3. select F10
  
Actual results:
hangs

Expected results:
installs F10 successfully

Additional info:
Comment 1 Gerry Reno 2009-03-23 02:01:32 EDT
I just noticed on the machine above that the md raid is syncing an array.  And I had noticed one other time that you can get weird hangs when there is array syncing going on and you have lots of disk activity.  So I'll wait until this array is synced and then try the preupgrade again.
Comment 2 Will Woods 2009-03-23 14:11:47 EDT
The missing dependencies are not important - we ignore them and so does anaconda.

Unless there's a traceback on the console (or in ~/.xsession-errors) this is probably just a disk IO problem.

Can you reproduce this when you're not in the midst of an mdraid sync? Is there a traceback?
Comment 3 Gerry Reno 2009-03-23 15:18:33 EDT
I tried this 3 times with the array syncing and each time preupgrade would hang at the Generating metadata point.

I then tried preupgrade after the mdraid array was finished syncing and then preuprade completed with no problem.

Just a little more evidence that mdraid syncing has some vulnerabilities.


Please close the bug.  Not a preupgrade problem.

Note You need to log in before you can comment on or make changes to this bug.