Bug 491605 - anaconda traceback from kickstart partitioning commands
anaconda traceback from kickstart partitioning commands
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-23 05:48 EDT by Mark McLoughlin
Modified: 2009-03-23 10:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 10:00:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-03-23 05:48:31 EDT
Tried to install the f11 beta tree from 2009-03-22 using a kickstart containing e.g.:

  part /boot --fstype ext3 --size=200 --onpart=sda1

and got this traceback:

  File "/usr/bin/anaconda", line 993, in <module>
    kickstart.processKickstartFile(anaconda, opts.ksfile)
  File "/usr/lib/anaconda/kickstart.py", line 1121, in processKickstartFile
    ksparser.readKickstart(file)
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 759, in readKickstart
    self._stateMachine (lambda: fh.readline())
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 634, in _stateMachine
    self.handleCommand(lineno, args)
  File "/usr/lib/anaconda/kickstart.py", line 1088, in handleCommand
    KickstartParser.handleCommand(self, lineno, args)
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 467, in handleCommand
    self.handler.dispatcher(args, lineno, self._preceededInclude)
  File "/usr/lib/python2.6/site-packages/pykickstart/base.py", line 376, in dispatcher
    obj = self.commands[cmd].parse(args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 678, in parse
    devicetree.registerAction(ActionCreateFormat(device, kwargs["format"]))
  NameError: global name 'ActionCreateFormat' is not defined

Looks like kickstart.py is missing:

  from storage.deviceaction import *
Comment 1 Chris Lumens 2009-03-23 10:00:36 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.