Bug 491610 - Attachments in forwarded messages are corrupted on saving
Attachments in forwarded messages are corrupted on saving
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 06:11 EDT by Ian
Modified: 2009-04-08 12:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 12:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of properly forwarded email (84.45 KB, application/rfc822)
2009-04-08 12:09 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Ian 2009-03-23 06:11:28 EDT
Description of problem:
Saving attachment from a forwarded message produces an 18-byte
file with some html in it.

Version-Release number of selected component (if applicable):
2.0.0.21 and previous

How reproducible:
Always

Steps to Reproduce:
1. Make sure you have "Forward messages" set to "As Attachment" in
   Preferences->Composition->General Tab.
2. Send message to self with an attachment (I used .doc)
3. Forward received message to self (should go out as a .eml attachment)
4. On receipt, double click .eml attachment, then right click and save the
   original attached document.

Actual results:
Attachment corrupted (is always a closing body and html tagset)

Expected results:
Original attachment!

Additional info:
Double clicking attachment seems to load into Office fine.
Might, just possibly, be some interaction with dovecot (running 1.1.13)
Running dovecot-1.1.13 as IMAP server.
Comment 1 Matěj Cepl 2009-04-08 12:09:49 EDT
Created attachment 338747 [details]
example of properly forwarded email

Just cannot reproduce.

Note You need to log in before you can comment on or make changes to this bug.