Bug 491620 - NM segfaults after trying to connect to previously connected AP (sugar)
NM segfaults after trying to connect to previously connected AP (sugar)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 07:45 EDT by Simon Schampijer
Modified: 2009-05-12 00:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.7.0.99-4.git20090324.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:12:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (7.05 KB, text/plain)
2009-03-23 11:59 EDT, Tomeu Vizoso
no flags Details
message log of failures after applying this fix. (31.94 KB, text/plain)
2009-03-26 10:26 EDT, Kelvin J. Hill
no flags Details

  None (edit)
Description Simon Schampijer 2009-03-23 07:45:03 EDT
Description of problem:
NM segfaults after trying to connect to previously connected AP. Sugar starts and hands the secrets to NM and NM does crash.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.99-3.5.git20090318.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. log into sugar and connect to an AP
2. log out
3. log in again - the connection with the Ap does happen automatically
  
Actual results:

Mar 23 12:22:46 localhost NetworkManager: <info>  Activation (wlan0/wireless): connection 'Auto pennylane' has security, and secrets exist.  No new secrets needed.
Mar 23 12:22:46 localhost NetworkManager: <info>  Config: added 'ssid' value 'pennylane'
Mar 23 12:22:46 localhost NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Mar 23 12:22:46 localhost NetworkManager: <info>  Config: added 'key_mgmt' value 'NONE'
Mar 23 12:22:46 localhost NetworkManager: <info>  Config: added 'wep_key0' value '<omitted>'
Mar 23 12:22:46 localhost NetworkManager: <info>  Config: added 'wep_tx_keyidx' value '0'
Mar 23 12:22:46 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 23 12:22:46 localhost NetworkManager: <info>  Config: set interface ap_scan to 1
Mar 23 12:22:46 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> disconnected
Mar 23 12:22:46 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning
Mar 23 12:22:47 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associating
Mar 23 12:22:47 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  associating -> associated
Mar 23 12:22:47 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  associated -> completed
Mar 23 12:22:47 localhost NetworkManager: <info>  Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'pennylane'.
Mar 23 12:22:47 localhost NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Mar 23 12:22:47 localhost NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Mar 23 12:22:47 localhost NetworkManager: <info>  (wlan0): device state change: 5 -> 7
Mar 23 12:22:47 localhost NetworkManager: <info>  Activation (wlan0) Beginning DHCP transaction.
Mar 23 12:22:47 localhost dhclient: Internet Systems Consortium DHCP Client 4.1.0
Mar 23 12:22:47 localhost dhclient: Copyright 2004-2008 Internet Systems Consortium.
Mar 23 12:22:47 localhost dhclient: All rights reserved.
Mar 23 12:22:47 localhost dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Mar 23 12:22:47 localhost dhclient: 
Mar 23 12:22:47 localhost NetworkManager: <info>  dhclient started with pid 10553
Mar 23 12:22:47 localhost NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Mar 23 12:22:47 localhost NetworkManager: <info>  DHCP: device wlan0 state changed normal exit -> preinit
Mar 23 12:22:47 localhost dhclient: Listening on LPF/wlan0/00:17:9a:b1:22:5d
Mar 23 12:22:47 localhost dhclient: Sending on   LPF/wlan0/00:17:9a:b1:22:5d
Mar 23 12:22:47 localhost dhclient: Sending on   Socket/fallback
Mar 23 12:22:48 localhost NetworkManager: nm_ip4_config_get_dbus_path: assertion `NM_IS_IP4_CONFIG (config)' failed
Mar 23 12:22:48 localhost NetworkManager: <WARN>  nm_signal_handler(): Caught signal 11.  Generating backtrace...
Mar 23 12:22:48 localhost NetworkManager: ******************* START **********************************
Mar 23 12:22:48 localhost NetworkManager: ******************* END **********************************
Mar 23 12:22:48 localhost pulseaudio[10538]: module-alsa-sink.c: Increasing wakeup watermark to 5.99 ms
Mar 23 12:22:48 localhost pulseaudio[10538]: module-alsa-source.c: Increasing wakeup watermark to 5.99 ms
Mar 23 12:22:50 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Mar 23 12:22:50 localhost dhclient: DHCPOFFER from 192.168.0.1
Mar 23 12:22:50 localhost dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Mar 23 12:22:50 localhost dhclient: DHCPACK from 192.168.0.1
Mar 23 12:22:50 localhost dhclient: bound to 192.168.0.102 -- renewal in 410086263 seconds.
Comment 1 Simon Schampijer 2009-03-23 08:06:03 EDT
looks a bit like what is described here: http://www.nabble.com/Segment-fault-when-using-wireless-%28adhoc-mode%29-td22283535.html
Comment 2 Simon Schampijer 2009-03-23 09:17:20 EDT
I seem to hit it after logout. After restart it was fine, as well after the first logout - but not after the second one.
Comment 3 Tomeu Vizoso 2009-03-23 11:59:33 EDT
Created attachment 336309 [details]
backtrace
Comment 4 Dan Williams 2009-03-23 15:12:13 EDT
Probably triggered by a GetAll of the device's properties right after a state change to ip-configure state.  Should be fixed upstream in 31539034b306ea2b324ffb85f776b6a5e0b38acf.
Comment 5 Fedora Update System 2009-03-24 10:54:31 EDT
NetworkManager-0.7.0.99-4.git20090324.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-4.git20090324.fc10
Comment 6 Fedora Update System 2009-03-24 10:57:41 EDT
NetworkManager-0.7.0.99-4.git20090324.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-4.git20090324.fc9
Comment 7 Simon Schampijer 2009-03-24 16:22:02 EDT
Verified fix in F11 - is working fine now for me.
Comment 8 Fedora Update System 2009-03-25 12:11:49 EDT
NetworkManager-0.7.0.99-4.git20090324.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Kelvin J. Hill 2009-03-26 10:25:10 EDT
I am sorry to say that this update has proved to be a disaster for me.
It seems to be incompatible with either the Cisco VPN client driver or VMWare Workstation network drivers.

If neither if these are loaded, NetworkManager starts as expected. If however, either is loaded, NetworkManager immediately crashes.

I have attached a sanitized logfile extract demonstrating the problem. I guess I will have to revert back to the previous version.
Comment 10 Kelvin J. Hill 2009-03-26 10:26:05 EDT
Created attachment 336813 [details]
message log of failures after applying this fix.
Comment 11 Fedora Update System 2009-03-26 18:05:00 EDT
NetworkManager-0.7.0.99-5.git20090326.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-5.git20090326.fc9
Comment 12 Matt Richard 2009-03-27 23:15:13 EDT
I also see the same problem with this fix as Kelvin reported.  When I reverted to NetworkManager-0.7.0.99-3.fc10.x86_64 (etc) the problem disappeared completely.
Comment 13 Fedora Update System 2009-04-08 23:04:13 EDT
NetworkManager-0.7.0.100-2.git20090408.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.100-2.git20090408.fc9
Comment 14 Fedora Update System 2009-04-14 21:23:39 EDT
NetworkManager-0.7.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.1-1.fc9
Comment 15 Fedora Update System 2009-05-12 00:06:52 EDT
NetworkManager-0.7.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.