Bug 491641 - Package rhnpush contains /usr/bin/solaris2mpm which needs pkgtrans, that one is not Required
Package rhnpush contains /usr/bin/solaris2mpm which needs pkgtrans, that one ...
Status: CLOSED WONTFIX
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: 600263 space16
  Show dependency treegraph
 
Reported: 2009-03-23 09:30 EDT by Jan Pazdziora
Modified: 2011-09-02 08:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 600263 (view as bug list)
Environment:
Last Closed: 2011-09-02 08:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-03-23 09:30:45 EDT
Description of problem:

The package rhnpush in Spacewalk contains program /usr/bin/solaris2mpm which needs pkgtrans, that one is not Required. So running solaris2mpm fails. We should either Require appropriate package (heirloom-pkgtools comes to mind) or not ship /usr/bin/solaris2mpm in rhnpush.

Version-Release number of selected component (if applicable):

# type solaris2mpm
solaris2mpm is /usr/bin/solaris2mpm
# rpm -qf /usr/bin/solaris2mpm
rhnpush-0.4.6-1.el5

How reproducible:

Deterministic.

Steps to Reproduce:
1. Download package from http://www.download-ftp-center.com/sunfreeware.com/sparc/10/lsof-4.77-sol10-sparc-local.gz
2. Run solaris2mpm on that package.
  
Actual results:

# wget 'http://www.download-ftp-center.com/sunfreeware.com/sparc/10/lsof-4.77-sol10-sparc-local.gz'
--14:21:49--  http://www.download-ftp-center.com/sunfreeware.com/sparc/10/lsof-4.77-sol10-sparc-local.gz
Resolving www.download-ftp-center.com... 62.50.40.242
Connecting to www.download-ftp-center.com|62.50.40.242|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 475827 (465K) [application/x-gzip]
Saving to: `lsof-4.77-sol10-sparc-local.gz'

100%[========================================================================================================================>] 475,827     1.09M/s   in 0.4s   

14:21:49 (1.09 MB/s) - `lsof-4.77-sol10-sparc-local.gz' saved [475827/475827]

# solaris2mpm lsof-4.77-sol10-sparc-local.gz 
Opening archive, this may take a while
Decompressing archive
Error creating mpm for /root/lsof-4.77-sol10-sparc-local.gz:
Traceback (most recent call last):
  File "/usr/share/rhn/rhnpush/solaris2mpm.py", line 193, in _run
    archive_parser = get_archive_parser(archive, tempdir=options.TEMPDIR)
  File "/usr/share/rhn/rhnpush/archive.py", line 423, in get_archive_parser
    return Class(archive, tempdir)
  File "/usr/share/rhn/rhnpush/archive.py", line 68, in __init__
    self._explode(archive)
  File "/usr/share/rhn/rhnpush/archive.py", line 107, in _explode
    cmd = self._explode_cmd()
  File "/usr/share/rhn/rhnpush/archive.py", line 293, in _explode_cmd
    raise ArchiveException("cannot open %s, 'pkgtrans' not found" % self._archive)
ArchiveException: cannot open /tmp/tmpY9XNbE/lsof-4.77-sol10-sparc-local, 'pkgtrans' not found

Expected results:

# wget 'http://www.download-ftp-center.com/sunfreeware.com/sparc/10/lsof-4.77-sol10-sparc-local.gz'
--14:22:10--  http://www.download-ftp-center.com/sunfreeware.com/sparc/10/lsof-4.77-sol10-sparc-local.gz
Resolving www.download-ftp-center.com... 62.50.40.242
Connecting to www.download-ftp-center.com|62.50.40.242|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 475827 (465K) [application/x-gzip]
Saving to: `lsof-4.77-sol10-sparc-local.gz'

100%[========================================================================================================================>] 475,827     1.09M/s   in 0.4s   

14:22:11 (1.09 MB/s) - `lsof-4.77-sol10-sparc-local.gz' saved [475827/475827]

# uname -a
Linux xen35.englab.brq.redhat.com 2.6.18-128.1.1.el5xen #1 SMP Mon Jan 26 14:34:58 EST 2009 i686 i686 i386 GNU/Linux
# rpm -qf /usr/bin/pkgtrans 
heirloom-pkgtools-1.070227-6.el5
# solaris2mpm lsof-4.77-sol10-sparc-local.gz 
Opening archive, this may take a while
Decompressing archive
Writing SMClsof-4.77-1_PSTAMP_Steve_Christensen.sparc-solaris.mpm

Additional info:

I've originally built heirloom-pkgtools package to be used during build-time for rhn-solaris-bootstrap package. However, it looks like it could be used on Spacewalk servers (and even on clients that want to run rhnpush) during runtime as well.

The proposed solution is to add heirloom-pkgtools to Spacewalk 0.5 compose and Require it (or /usr/bin/pkgtrans) in rhnpush.
Comment 1 Jan Pazdziora 2010-11-19 11:02:59 EST
Mass-moving to space13.
Comment 2 Miroslav Suchý 2011-04-11 03:31:32 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 3 Miroslav Suchý 2011-04-11 03:36:26 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 4 Jan Pazdziora 2011-07-20 07:49:09 EDT
Aligning under space16.
Comment 5 Jan Pazdziora 2011-09-02 08:12:29 EDT
We did not have users complain about this issue, closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.