Bug 491666 - Network Manager should not manage online/offline state if not all interfaces are NM managed
Network Manager should not manage online/offline state if not all interfaces ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 10:47 EDT by Michael DeHaan
Modified: 2009-03-23 14:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 12:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael DeHaan 2009-03-23 10:47:48 EDT
Description of problem:

I have two interfaces -- one wired and one wireless.  I have the wired interface set to be /not/ managed by Network manager because I want virtualization to function.   When I start firefox, since NM has knowledge of Firefox (or vice versa) it comes up in "offline" mode when NM is enabled.   What I want is for NM to manage only the wireless connection and firefox to start up in online mode all of the time, with NM not affecting Firefox online/offline state.

Version-Release number of selected component (if applicable):

rpm -q NetworkManager
NetworkManager-0.7.0.99-3.fc10.i386
rpm -q firefox
firefox-3.0.7-1.fc10.i386

How reproducible:

Always

Steps to Reproduce:
1.   Configure ifcfg-eth0 to not be network manager managed, restart system
2.   System is connected to wireless only

  
Actual results:

Firefox comes up in offline mode and does not remember online setting

Expected results:

Firefox comes up in online mode, without me having to pick File->Work Online each time I start it, which is annoying.
Comment 1 Dan Williams 2009-03-23 12:38:50 EDT
NM is intended to control the primary network connection.  If NM isn't controlling the primary network connection, then you may not want to use NM.  If you've made your primary network connection ignored by NM, then of course NM is going to do things like moving your default route to its idea of the current default device, and rewriting /etc/resolv.conf, etc.

The solution is to add bridging support to NetworkManager, which is something I'm working on.  Until that point, this is expected behavior because your primary network connection device is ignored by NM.
Comment 2 Michael DeHaan 2009-03-23 12:46:44 EDT
How about a simple checkbox or something to say "don't manage firefox" ?
Comment 3 Dan Williams 2009-03-23 13:23:51 EDT
There's a firefox preference setting that you can use to toggle FF's behavior on and off.  I forget offhand what that is.  There's a pretty long FF bug about it in mozilla bugzilla.
Comment 4 Michael DeHaan 2009-03-23 14:09:30 EDT
Answer for those arriving via Google:

In firefox's location bar, type "about:config" <ENTER>

Change the following setting:

toolkit.networkmanager.disable

to "true"

Then everything works as expected.

Note You need to log in before you can comment on or make changes to this bug.