Bug 491670 - proxy installer, initial package removal on conflicting rpms fails
proxy installer, initial package removal on conflicting rpms fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Tomas Lestach
https://riverraid.rhndev.redhat.com/n...
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-03-23 11:05 EDT by wes hayutin
Modified: 2009-09-10 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-23 11:05:07 EDT
Description of problem:

Satellite-5.3.0-RHEL5-re20090320.0-i386-embedded-oracle.iso
proxy installer, initial package removal on conflicting rpms fails


recreate.
1. yum install httpd
2. install proxy via webui

results:
 	This action will be executed after 03/23/09 11:01:24 AM EDT.

This action's status is: Failed.
The client picked up this action on 03/23/09 11:01:39 AM EDT.
The client completed this action on 03/23/09 11:01:39 AM EDT.
Client execution returned "Script failed" (code 1)


Run as: root:root
Timeout: 600 seconds

#!/bin/sh
rpm -e `for package in httpd-suexec; do
rpm -q $package >/dev/null && echo $package; done`


Start Date: 2009-03-23 11:01:39
End Date: 2009-03-23 11:01:39
Return Code: 256
Raw Output: view/download raw script output
Filtered Output:

error: Failed dependencies:
httpd-suexec is needed by (installed) httpd-2.0.52-41.ent.2.i386




wondering why we're passing rpm commands and not using yum/up2date
Comment 1 Miroslav Suchý 2009-03-25 09:55:24 EDT
Because up2date can only install/upgrade package, not remove. So we use program that is common to both rhel4 and rhel5.

You should not manually install httpd. We require only @base installed.

But yes, if you are trying remove 5.3 proxy you can see that

There has been several others conflicts during upgrades from older releases of proxy.
Fixed in commits:
e8db4f087e18a32cefecbc301680ac87388c39d8
7806888cec9a4100ee0e78cb93549056b8d2f6fd
12dac0fed153fe79093f6a2f46da99d07687e176
150b5765a14856fb46ce56428840bc63dcbffa35
Comment 2 wes hayutin 2009-03-30 14:40:57 EDT
had a problem installing proxy on a box that had rhnmd installed..
The removal script failed..

looking for a comment on whether or not that is a problem.
Comment 3 Miroslav Suchý 2009-03-31 03:35:14 EDT
This is new thing, since previously rhnmd conflicts with monitoring itself. 
I will investigate it.
Comment 4 Tomas Lestach 2009-07-01 06:01:33 EDT
I installed httpd and rhnmd on a client and then I activated proxy on this client over WEBUI + running rhn_check on the client.

From WEBUI:
-------------------------------------------------------------------------------
Installing RHN Proxy Server
Install progress

You are installing Satellite Proxy on this system. Below is the list of actions for this installation.

   1. Remove conflicting proxy packages - Completed
   2. Package Installs - Completed
   3. Deploy Configuration - Completed
   4. Allow Proxy service to read Satellite Configuration - Completed
   5. Enable Satellite Proxy services - Completed
   6. Start Satellite Proxy - Completed

The installation is complete.
-------------------------------------------------------------------------------
RHN Proxy

This machine is currently a licensed RHN Proxy (v5.3).
-------------------------------------------------------------------------------

Installation run without problems.

After installation, httpd and rhnmd are still installed:
# rpm -q httpd rhnmd
httpd-2.2.3-22.el5_3.1
rhnmd-5.3.0-4.el5sat

Another client registered to the proxy was able to install packages.
Comment 5 John Matthews 2009-08-07 13:51:42 EDT
Move to RELEASE_PENDING

I installed httpd and rhnmd prior to setting up the proxy, proxy was installed/configured correctly.

1) yum install httpd rhnmd
  [root@dhcp77-237 ~]# rpm -q httpd
  httpd-2.2.3-22.el5_3.1
  [root@dhcp77-237 ~]# rpm -q rhnmd
  rhnmd-5.3.0-4.el5sat
2) yum install spacewalk-proxy-installer
3) configure-proxy.sh
Starting rhn-proxy...
init_cache_dir /var/spool/squid... Starting squid: .       [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Jabber services                                   [  OK  ]
Done.

[root@dhcp77-237 ~]# rpm -q httpd
httpd-2.2.3-22.el5_3.1
[root@dhcp77-237 ~]# rpm -q rhnmd
rhnmd-5.3.0-4.el5sat


Registered a client through rhn-proxy
installed package successfully
Comment 6 Tomas Lestach 2009-08-10 04:14:47 EDT
Hi John, according to the reproducer in the #Description proxy installation shall be done via webui, not via cli.
Comment 7 John Matthews 2009-08-10 17:12:58 EDT
Hi Tomas,

Thanks for pointing that out, I re-tested this with a webui install of the proxy.
I saw it schedule the removal of httpd and the proxy install completed correctly, the box is now a functional proxy.
Comment 8 Brandon Perkins 2009-09-10 10:38:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.