Bug 491696 - rhnmd never generates SSH2 DSA host key.. or restarts correctly
rhnmd never generates SSH2 DSA host key.. or restarts correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
na
:
Depends On:
Blocks: 463877 486216
  Show dependency treegraph
 
Reported: 2009-03-23 12:56 EDT by wes hayutin
Modified: 2009-09-10 14:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-23 12:56:15 EDT
Description of problem:

rhnmd never generates SSH2 DSA host key.. or restarts correctly

nocpulse:x:101:102:RHNMD daemon:/var/lib/nocpulse:/bin/bash
[root@rlx-2-04 rhn]# /etc/init.d/rhnmd restart
Stopping rhnmd:                                            [FAILED]
Generating SSH2 DSA host key:                              [FAILED]
[root@rlx-2-04 rhn]# rpm -q rhnmd
rhnmd-5.1.6-1.el5sat
[root@rlx-2-04 rhn]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.3 (Tikanga)
[root@rlx-2-04 rhn]# getenforce 
Permissive
[root@rlx-2-04 rhn]# 


[root@fjs-0-18 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)
[root@fjs-0-18 ~]# rpm -q rhnmd
rhnmd-5.1.6-1.el4sat
[root@fjs-0-18 ~]# /etc/init.d/rhnmd restart
Stopping rhnmd:                                            [FAILED]
Generating SSH2 DSA host key:                              [FAILED]
[root@fjs-0-18 ~]# getenforce 
Permissive
[root@fjs-0-18 ~]#
Comment 1 wes hayutin 2009-03-23 17:30:15 EDT
The problem is in TWO places


1.
[root@rlx-3-06 nocpulse]/etc/nocpulse/rhnmd_config 

HostKey /etc/nocpulse/ssh_host_dsa_key


[root@rlx-3-06 nocpulse]# ls /etc/nocpulse/
rhnmd_config
[root@rlx-3-06 nocpulse]# 



2. /etc/init.d/rhnmd

DSA_KEY=/etc/nocpulse/ssh_host_dsa_key
Comment 2 Miroslav Suchý 2009-03-25 11:06:31 EDT
That generation should never occur since nocpulse-common do that now during installation.

It has been removed in rhnmd-5.1.7-1, but it did not reached latest ISO.

[15:57] <msuchy> dgilmore: looking on rhnmd   /mnt/redhat/devel/candidate-trees/RHN-Tools-5.3.0-RHEL4-re20090323.0/i386/i386/RHNTools/rhnmd-5.1.6-1.el4sat.i386.rpm
[15:57] <msuchy> dgilmore: but rhnmd-5.1.7-1 has been taged 
[15:57] <msuchy> dgilmore: on 2009-03-11
[15:57] <msuchy> dgilmore: how it come that on latest iso is old rhnmd?
[15:58] <msuchy> dgilmore: is the tools comps still somehow unfinished?
[15:58] <dgilmore> msuchy: thats the latest that is built
[15:59] <dgilmore> https://brewweb.devel.redhat.com/packageinfo?packageID=4623
[16:00] <msuchy> zeus: ^
[16:04] <msuchy> zeus: so will you build it?
[16:04] <zeus> msuchy, building. I skipped it. I have to clean up the missing builds script to report what's TRULY requires building.
[16:04] <zeus> msuchy, building now


Please retest it with new ISO. Should then work cleanly.
Comment 3 Miroslav Suchý 2009-03-30 04:24:30 EDT
rhnmd-5.1.7-1 is on latest ISO
Comment 4 wes hayutin 2009-04-02 13:16:18 EDT
Installed: rhnmd.i386 0:5.1.7-1.el5sat
Dependency Installed: nocpulse-common.noarch 0:2.1.8-1.el5sat perl-Compress-Zlib.i386 0:1.42-1.fc6 perl-DBI.i386 0:1.52-2.el5 perl-HTML-Parser.i386 0:3.55-1.fc6 perl-HTML-Tagset.noarch 0:3.10-2.1.1 perl-IO-stringy.noarch 0:2.109-11.el5 perl-libwww-perl.noarch 0:5.805-1.1.1
Complete!
[root@dhcp77-135 ~]# /etc/init.d/rhnmd restart
Stopping rhnmd:                                            [FAILED]
Starting rhnmd:                                            [  OK  ]
[root@dhcp77-135 ~]# rpm -ql rhnmd
/etc/nocpulse/rhnmd_config
/etc/pam.d/rhnmd
/etc/rc.d/init.d/rhnmd
/usr/lib/librhnmdwrap.so
/usr/sbin/rhnmd
/usr/sbin/rhnmd-wrap
/usr/share/doc/rhnmd-5.1.7
/usr/share/doc/rhnmd-5.1.7/LICENSE
/var/lib/nocpulse/.ssh/authorized_keys
[root@dhcp77-135 ~]# 


verified
Comment 5 Milan Zázrivec 2009-09-02 10:29:34 EDT
rhnmd-5.3.0-4 installation creates ssh keys correctly, restart works ok.
RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 14:15:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.