Bug 491709 - refuses to start newly-created guests
refuses to start newly-created guests
Status: CLOSED DUPLICATE of bug 491052
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 13:36 EDT by Bill Nottingham
Modified: 2014-03-16 23:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 17:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-03-23 13:36:38 EDT
Description of problem:

Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: char device redirected to /dev/pts/4
char device redirected to /dev/pts/5

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1485, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 973, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: char device redirected to /dev/pts/4
char device redirected to /dev/pts/5

Version-Release number of selected component (if applicable):

virt-manager-0.7.0-1.fc11.x86_64
qemu-system-x86-0.10-0.9.kvm20090310git.fc11.x86_64
kernel-2.6.29-0.258.rc8.git2.fc11.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Create a F9 x86 or x86_64 guest, URL install
2. Click on 'GO, DO IT'
3. Watch it download the boot images and...
  
Actual results:

... no virt image created.
Comment 1 Bill Nottingham 2009-03-23 13:40:35 EDT
virt logs show:

qemu: could not load kernel '/home/notting/.virtinst/boot/virtinst-vmlinuz.KQDTlP'

And, ausearch yields gems like:

type=AVC msg=audit(1237829513.064:2400): avc:  denied  { open } for  pid=3292 comm="libvir
td" name="kvm" dev=tmpfs ino=7738 scontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tconte
xt=system_u:object_r:kvm_device_t:s0 tclass=chr_file

and:

type=AVC msg=audit(1237829478.894:2395): avc:  denied  { getattr } for  pid=3293 comm="lib
virtd" scontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_
r:unconfined_t:s0-s0:c0.c1023 tclass=process

and:

type=AVC msg=audit(1237829613.856:2406): avc:  denied  { read } for  pid=2982 comm="qemu-k
vm" name="virtinst-vmlinuz.b_MwkR" dev=dm-0 ino=12056 scontext=system_u:system_r:svirt_t:s
0:c261,c919 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

So, I turn off enforcing. Now I get:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 272, in show_details
    details = vmmDetails(self.get_config(), con.get_vm(uuid), self)
  File "/usr/share/virt-manager/virtManager/details.py", line 337, in __init__
    self.update_widget_states(self.vm, self.vm.status())
  File "/usr/share/virt-manager/virtManager/details.py", line 783, in update_widget_states
    self.set_migrate_menu()
  File "/usr/share/virt-manager/virtManager/details.py", line 730, in set_migrate_menu
    self.engine.populate_migrate_menu(menu, self.control_vm_migrate)
  File "/usr/share/virt-manager/virtManager/engine.py", line 578, in populate_migrate_menu
    conns = self.get_available_migrate_hostnames()
  File "/usr/share/virt-manager/virtManager/engine.py", line 601, in get_available_migrate_hostnames
    driver = self.windowManager.current_connection().get_driver()
AttributeError: 'NoneType' object has no attribute 'get_driver'

where the qemu messages in the libvirtd log are just:

qemu: loading initrd (0x97a469 bytes) at 0x000000003f675000
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection ref
used

HOME environment variable not set?
info cpus
* CPU #0: pc=0x00000000000ffff0 thread_id=3324
cont
Comment 2 Bill Nottingham 2009-03-23 13:45:32 EDT
Ah, note that in the last case, it manages to create it despite the error. (As in 491052). But there are definitely SELinux issues creating it in the first place.
Comment 3 Bill Nottingham 2009-03-23 14:08:41 EDT
Also also, it seems rather slow. But I can't quantify that to anything in particular.
Comment 4 Cole Robinson 2009-03-23 17:56:57 EDT
I know mark pointed you to open a different a bug, but I'm pretty sure this is all the same issues being tracked in 491052 (see Comment #11 in that bug).

*** This bug has been marked as a duplicate of bug 491052 ***

Note You need to log in before you can comment on or make changes to this bug.