Bug 491715 - kernel panic with kernel version 2.6.9-78.ELhugemem
kernel panic with kernel version 2.6.9-78.ELhugemem
Status: CLOSED DUPLICATE of bug 455074
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
i386 Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 14:04 EDT by Sebastien Ruel
Modified: 2009-07-13 10:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 10:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastien Ruel 2009-03-23 14:04:51 EDT
Description of problem:
Kernel panic with three of our servers. The systems had to be rebooted each time. We didn't find the conditions to reproduce the BUG. It seems to occur randomly. 

Version-Release number of selected component (if applicable):
2.6.9-78.ELhugemem

How reproducible:
We don't know how to reproduce the bug. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Mar 22 17:06:13 sedefx05 kernel: ------------[ cut here ]------------
Mar 22 17:06:13 sedefx05 kernel: kernel BUG at kernel/exit.c:904!
Mar 22 17:06:13 sedefx05 kernel: invalid operand: 0000 [#1]
Mar 22 17:06:13 sedefx05 kernel: SMP
Mar 22 17:06:13 sedefx05 kernel: Modules linked in: nfs lockd nfs_acl sg mptctl mptbase dell_rbu parport_pc lp parport autofs4 i2c_dev i2c_core ipmi_devintf
ipmi_si ipmi_msghandler sunrpc cpufreq_powersave dm_mirror dm_multipath button battery ac hw_random e1000 bnx2 bonding(U) sr_mod ext3 jbd dm_mod usb_storage
uhci_hcd ohci_hcd ehci_hcd ata_piix libata megaraid_sas(U) sd_mod qla2xxx(U) scsi_mod qla2xxx_conf(U)
Mar 22 17:06:13 sedefx05 kernel: CPU:    13
Mar 22 17:06:13 sedefx05 kernel: EIP:    0060:[<02124c55>]    Not tainted VLI
Mar 22 17:06:13 sedefx05 kernel: EFLAGS: 00010046   (2.6.9-78.ELhugemem)
Mar 22 17:06:13 sedefx05 kernel: EIP is at next_thread+0xc/0x3f
Mar 22 17:06:13 sedefx05 kernel: eax: 00000000   ebx: 70cbb330   ecx: 004dcff4   edx: 70cba830
Mar 22 17:06:13 sedefx05 kernel: esi: 0000a5a8   edi: 0000c969   ebp: 4230a000   esp: 4230af8c
Mar 22 17:06:13 sedefx05 kernel: ds: 007b   es: 007b   ss: 0068
Mar 22 17:06:13 sedefx05 kernel: Process emagent (pid: 22450, threadinfo=4230a000 task=70cbb330)
Mar 22 17:06:13 sedefx05 kernel: Stack: 0212e92d f4d94130 f4d941bc 4230a000 02156fc7 00000001 f4d94130 00000000
Mar 22 17:06:13 sedefx05 kernel:        0212615f 4230afc4 f61f3fcc f4d941e8 4230a000 fffec220 f4d94138 004dcff4
Mar 22 17:06:13 sedefx05 kernel:        f61f3fcc f61f3fcc f4d941e8 f4d94170 0000002b fffe007b 0000007b 0000002b
Mar 22 17:06:13 sedefx05 kernel: Call Trace:
Mar 22 17:06:13 sedefx05 kernel:  [<0212e92d>] sys_times+0x55/0x192
Mar 22 17:06:13 sedefx05 kernel:  [<02156fc7>] put_user_size+0x29/0x2d
Mar 22 17:06:13 sedefx05 kernel:  [<0212615f>] sys_gettimeofday+0x25/0x55
Mar 22 17:06:13 sedefx05 kernel: Code: 85 c0 89 d3 74 05 e8 ba 9d ff ff 53 e8 b9 fb ff ff 0f b6 44 24 04 c1 e0 08 50 e8 ab fb ff ff 89 c2 8b 80 f0 04 00 00 8
5 c0 75 08 <0f> 0b 88 03 cf a1 2e 02 0f b6 80 04 05 00 00 84 c0 7e 14 a1 80
Mar 22 17:06:13 sedefx05 kernel:  <0>Fatal exception: panic in 5 seconds
Comment 1 amar.darisa 2009-03-31 05:43:52 EDT
Have got same happening on kernel version 2.6.9-78.ELsmp #1 SMP
Kernel has panicked and shutdown twice in less than 12 hours.

Mar 31 05:53:19 venturacn12 kernel: ------------[ cut here ]------------
Mar 31 05:53:19 venturacn12 kernel: kernel BUG at kernel/exit.c:904!
Mar 31 05:53:19 venturacn12 kernel: invalid operand: 0000 [#1]
Mar 31 05:53:19 venturacn12 kernel: SMP 
Mar 31 05:53:19 venturacn12 kernel: Modules linked in: parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc cpufreq_powersave dm_mirror dm_mod button battery ac md5 ipv6 joydev uhci_hcd ehci_hcd i5000_edac edac_mc hw_random bnx2 ext3 jbd ata_piix libata aacraid sd_mod scsi_mod
Mar 31 05:53:19 venturacn12 kernel: CPU:    5



Mar 31 14:26:43 venturacn12 kernel: kernel BUG at kernel/exit.c:904!
Mar 31 14:26:43 venturacn12 kernel: invalid operand: 0000 [#1]
Mar 31 14:26:43 venturacn12 kernel: SMP 
Mar 31 14:26:43 venturacn12 kernel: Modules linked in: parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc cpufreq_powersave dm_mirror dm_mod button battery ac md5 ipv6 joydev uhci_hcd ehci_hcd i5000_edac edac_mc hw_random bnx2 ext3 jbd ata_piix libata aacraid sd_mod scsi_mod
Mar 31 14:26:43 venturacn12 kernel: CPU:    5
Mar 31 14:26:43 venturacn12 kernel: EIP:    0060:[<c0124cc5>]    Not tainted VLI
Mar 31 14:26:43 venturacn12 kernel: EFLAGS: 00010046   (2.6.9-78.ELsmp) 
Mar 31 14:26:43 venturacn12 kernel: EIP is at next_thread+0xc/0x3f
Mar 31 14:26:43 venturacn12 kernel: eax: 00000000   ebx: f477cdb0   ecx: 002faff4   edx: f2faf8b0
Mar 31 14:26:43 venturacn12 kernel: esi: 00000367   edi: 00000140   ebp: 07e64a20   esp: e1addf8c
Mar 31 14:26:43 venturacn12 kernel: ds: 007b   es: 007b   ss: 0068
Mar 31 14:26:43 venturacn12 kernel: Process httpd (pid: 18007, threadinfo=e1add000 task=f477cdb0)
Mar 31 14:26:43 venturacn12 kernel: Stack: c012f536 00000026 088cc6d8 00000005 00000000 00000050 0000001e 00000000 
Mar 31 14:26:43 venturacn12 kernel:        00000000 07e64a20 00000064 086d0b58 e1add000 c02e09db 07e64a20 002faff4 
Mar 31 14:26:43 venturacn12 kernel:        002faff4 00000064 086d0b58 07e64a38 0000002b c02e007b 0000007b 0000002b 
Mar 31 14:26:43 venturacn12 kernel: Call Trace:
Mar 31 14:26:43 venturacn12 kernel:  [<c012f536>] sys_times+0x56/0x1c5
Mar 31 14:26:43 venturacn12 kernel:  [<c02e09db>] syscall_call+0x7/0xb
Mar 31 14:26:43 venturacn12 kernel:  [<c02e007b>] __lock_text_end+0x880/0x107d
Mar 31 14:26:43 venturacn12 kernel: Code: 85 c0 89 d3 74 05 e8 53 9c ff ff 53 e8 b9 fb ff ff 0f b6 44 24 04 c1 e0 08 50 e8 ab fb ff ff 89 c2 8b 80 f0 04 00 00 85 c0 75 08 <0f> 0b 88 03 ae 25 2f c0 0f b6 80 04 05 00 00 84 c0 7e 14 a1 80 
Mar 31 14:26:43 venturacn12 kernel:  <0>Fatal exception: panic in 5 seconds
Comment 2 Prarit Bhargava 2009-03-31 10:16:46 EDT
We reverted a patch that caused this issue a while ago

http://people.redhat.com/~vgoyal/rhel4/RPMS.kernel/

should have kernels that do not have this problem.

P.

*** This bug has been marked as a duplicate of bug 455074 ***

Note You need to log in before you can comment on or make changes to this bug.