Bug 491722 - Installing Rawhide (clearpart --linux) on top of RAID1 formatted system fails
Installing Rawhide (clearpart --linux) on top of RAID1 formatted system fails
Status: CLOSED DUPLICATE of bug 491754
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-23 14:36 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 09:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (175.66 KB, text/plain)
2009-03-23 14:36 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (168.31 KB, text/plain)
2009-03-23 14:47 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (141.35 KB, text/plain)
2009-03-23 14:47 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (141.05 KB, text/plain)
2009-03-23 14:47 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (210.27 KB, text/plain)
2009-04-14 12:23 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-23 14:36:10 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 800, in commit
    raise DeviceError("cannot commit to disk %s after %d attempts" % (self.name, maxTries,))
  File "/usr/lib/anaconda/storage/devices.py", line 1130, in create
    self.disk.commit()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 206, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 660, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 184, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: cannot commit to disk vda after 5 attempts
Comment 1 James Laska 2009-03-23 14:36:16 EDT
Created attachment 336341 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-03-23 14:45:30 EDT
Consistently hitting this bug while testing that rawhide can install on top of previous installations.  This test matrix focused on installing distros on top of raid1 storage, then installing rawhide.

First install raid1 (release noted below), then clearpart rawhide
GUEST   TEST                FROM                TO      RESULT
=================================================================
vguest1 clearpart --linux   RHEL-4-U7           rawhide FAIL (bug#491722)
vguest2 clearpart --linux   RHEL-5-Server-U3    rawhide FAIL (bug#491722)
vguest3 clearpart --linux   F-10-GOLD           rawhide FAIL (bug#491722)
vguest4 clearpart --linux   F-9-GOLD            rawhide FAIL (bug#491722)
Comment 3 James Laska 2009-03-23 14:46:41 EDT
One a system that hits this failure ...

sh-4.0# cat /proc/mdstat
Personalities : [raid0] [raid1] [raid6] [raid5] [raid4] [raid10] [linear] 
unused devices: <none>
Comment 4 James Laska 2009-03-23 14:47:10 EDT
Created attachment 336344 [details]
Attached traceback automatically from anaconda.
Comment 5 James Laska 2009-03-23 14:47:28 EDT
Created attachment 336346 [details]
Attached traceback automatically from anaconda.
Comment 6 James Laska 2009-03-23 14:47:43 EDT
Created attachment 336348 [details]
Attached traceback automatically from anaconda.
Comment 7 Chris Lumens 2009-04-02 09:56:10 EDT

*** This bug has been marked as a duplicate of bug 491754 ***
Comment 8 James Laska 2009-04-14 12:23:40 EDT
Created attachment 339521 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.