Bug 491743 - Custom partitioning: swapon failed for /dev/sda2
Custom partitioning: swapon failed for /dev/sda2
Status: CLOSED DUPLICATE of bug 491529
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
StorageRewrite
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-23 15:57 EDT by Will Woods
Modified: 2009-03-23 16:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 16:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (270.19 KB, text/plain)
2009-03-23 15:57 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2009-03-23 15:57:53 EDT
Created attachment 336368 [details]
anacdump.txt

I attempted a simple custom partition layout - 3 bare partitions, no LVM: ext3 /boot, 1024MB swap, everything else / - in a KVM guest.

I got a traceback indicating that swapon seems to have failed - the message on tty5 says:
  "swapon: can't stat '/dev/sda2': No such file or directory"
but /dev/sda2 does exist. Perhaps there's a race between anaconda and udev here?

Full dump is attached. here's the traceback:

anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/swap.py", line 85, in swapon
    raise SwapError("swapon failed for '%s'" % device)
  File "/usr/lib/anaconda/storage/formats/swap.py", line 118, in setup
    swap.swapon(self.device, priority=self.priority)
  File "/usr/lib/anaconda/storage/__init__.py", line 1356, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/packages.py", line 193, in turnOnFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda.intf)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
SwapError: swapon failed for '/dev/sda2'
Comment 1 Chris Lumens 2009-03-23 16:31:14 EDT

*** This bug has been marked as a duplicate of bug 491592 ***
Comment 2 Chris Lumens 2009-03-23 16:31:26 EDT

*** This bug has been marked as a duplicate of bug 491529 ***

Note You need to log in before you can comment on or make changes to this bug.