Bug 491755 - virt-viewer jumps workspaces on guest restart with virt-install
Summary: virt-viewer jumps workspaces on guest restart with virt-install
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-viewer   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-23 20:42 UTC by Bill Nottingham
Modified: 2014-03-17 03:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 16:37:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2009-03-23 20:42:35 UTC
Description of problem:

I ran virt-install; it popped up virt-viewer. I moved the viewer to a different workspace.

Eventually the install finished, and the guest rebooted. When it did, virt-viewer jumped to the active workspace.

Version-Release number of selected component (if applicable):

virt-viewer-0.0.3-4.fc11.x86_64
python-virtinst-0.400.3-1.fc11.noarch

Comment 1 Mark McLoughlin 2009-03-25 16:31:31 UTC
Ah yes - we don't actually reboot; we shut down the guest and start it again

We need to do this because the config will have changed - e.g. you initially boot with vmlinuz/initrd but after install you want to boot with grub

Upshot is that we launch virt-viewer multiple times and there's no straightforward way of staying on the same workspace

Perhaps we could have a flag to not have virt-viewer shutdown when the guest shuts down, but rather automatically re-connect when the guest is started again

Not going to be a huge problem for most people, moving upstream.

Comment 2 Daniel Berrange 2009-03-25 19:00:08 UTC
Upstream virt-viewer (non-released) code does now have ability to wait for non-running VMs to startup, and also wait for them to restart upon shutdown, instead of exiting. There's a few more changes we need before we can release this code, so its a F12 kind of feature realistically.

Comment 3 Marc-Andre Lureau 2013-06-26 16:37:03 UTC
there is -w option for quite some time. Apparently virt-install makes use of it for quite some time. closing


Note You need to log in before you can comment on or make changes to this bug.