Bug 491768 - Traceback at CD switch attempt
Traceback at CD switch attempt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:4e80b01a5c5a2c84c...
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-23 18:27 EDT by Jesse Keating
Modified: 2013-01-09 22:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 19:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (188.63 KB, text/plain)
2009-03-23 18:28 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2009-03-23 18:27:58 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 346, in _switchCD
    dev.eject()
  File "/usr/lib/anaconda/yuminstall.py", line 507, in mediaHandler
    self._switchCD(discnum)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 735, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative = relative, text = text, copy_local = copy_local, url = url, mediaid = self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 820, in getHeader
    cache=cache,
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1394, in downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/anaconda/yuminstall.py", line 642, in downloadHeader
    YumSorter.downloadHeader(self, po)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 241, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/anaconda/yuminstall.py", line 771, in run
    self.populateTs(keepold=0)
  File "/usr/lib/anaconda/yuminstall.py", line 1577, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 287, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'eject'
Comment 1 Jesse Keating 2009-03-23 18:28:04 EDT
Created attachment 336406 [details]
Attached traceback automatically from anaconda.
Comment 2 Jesse Keating 2009-03-23 18:32:48 EDT
The only odd thing here is that I was using a USB cdrom drive rather than the one built in.
Comment 3 Chris Lumens 2009-03-24 11:25:08 EDT
This should be fixed in the next build of anaconda, though it's hard for me to test now because of the .discinfo problem.
Comment 4 Jesse Keating 2009-03-25 19:53:56 EDT
Confirmed fixed with the latest anaconda tagged for beta.

Note You need to log in before you can comment on or make changes to this bug.