Bug 49177 - Installer has long timeouts accessing IDE CD-ROM
Summary: Installer has long timeouts accessing IDE CD-ROM
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-16 16:12 UTC by G. Bersano
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 09:37:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description G. Bersano 2001-07-16 16:12:37 UTC
Description of problem:
During intallation process system seems to hang (ALL is frozen);
effectively it only is a loooong time out due to DMA.

How reproducible:
Always

Steps to Reproduce:
1. mount /mnt/cdrom

	

Actual Results:  After minutes the system returns to life

Expected Results:  Immediate rensponse.

Additional info:

System is compaq deskpro (Pentium III Katmai, 450 Mhz).
Upgraded to kernel-2.4.3.12.i686 but no results.

with latest kernel dmesg reports these relevant informations:

hdd: set_drive_speed_status: status=0x51 { DriveReady SeekComplete Error }
hdd: set_drive_speed_status: error=0xb4
hdd: ATAPI 48X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
hdd: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
scanning for RockRidge behind XA attributes
ISOFS: changing to secondary root
hdd: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14


If I disable DMA on that device (/sbin/hdparm -d0 /dev/hdd)
the problem disappears.

The drive, as identified by /proc/ide/hdd/model is an
CRD-8480B
(maybe LG?)

Question: is this - NO DMA - the best setup or is it possible to try any
option to use again DMA?

Comment 1 Arjan van de Ven 2001-07-18 09:37:45 UTC
I've not seen better options than disabling the DMA on the drive. This error
usually is a drive advertising DMA support but not actually supporting it; but
once in a while it's a bad cable.

Comment 2 G. Bersano 2001-07-18 10:13:39 UTC
Thanks, I'll stick with NO DMA as I don't think it's a bad cable.
Maybe add this CRD-8480B to the no-dma list ?

Comment 3 Arjan van de Ven 2001-07-18 10:27:14 UTC
Yup agreed; I just added it


Note You need to log in before you can comment on or make changes to this bug.