Bug 491777 - text console memory cache not swept when turning on drm
text console memory cache not swept when turning on drm
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 20:38 EDT by John Reiser
Modified: 2009-10-14 08:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 08:23:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg which covers boot (40.83 KB, text/plain)
2009-03-23 20:38 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2009-03-23 20:38:10 EDT
Created attachment 336416 [details]
dmesg which covers boot

Description of problem: The VGA text console displays stale memory cache data shortly after drm is turned on at boot.  The display corrects itself a few seconds later.


Version-Release number of selected component (if applicable):
kernel-2.6.29-0.258.rc8.git2.fc11.x86_64


How reproducible: always


Steps to Reproduce:
1. boot " vga=ask" and select mode 0x324 (1280x1024x16)
2. watch text console immediately after the "flash" when drm is turned on
3.
  
Actual results: Several lines of text have short runs of blank characters for a few seconds after drm is initialized, and the blanks get filled in with the proper characters "by magic" as the display scrolls for subsequent lines.


Expected results: No change in display (except for vertical scrolling) of lines which were preiviously output to text console.


Additional info: The bad display happens shortly after "[drm] Initialized drm 1.1.0 20060810" and looks like characters of several lines "usb N-1:M ..." have been overstruck by blanks.
Comment 1 Bug Zapper 2009-06-09 08:32:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jérôme Glisse 2009-10-14 07:18:06 EDT
don't add any vga option to your kernel boot line if you are using KMS this is know to give issue because vesa will mess with the GPU while KMS should be the only one messing with it. This should be fixed with newer kernel were vga option are ignored if KMS is enabled. Note that KMS will give you a console with native screen resolution (hence no need for special vga option). I will close this bug.

Note You need to log in before you can comment on or make changes to this bug.