Bug 4918 - Linuxconf rpm bugs
Linuxconf rpm bugs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-04 17:52 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-12 09:14:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 1999-09-04 17:52:43 EDT
There are a three problems when
doing an install or upgrade of linuxconf*.i386.rpm

1. It adds
  linuxconf 98/tcp
service to /etc/services and /etc/inetd.conf
even if this service already exists there.
If you do
rpm -Uvh linuxconf*.rpm
10 times the  linuxconf 98/tcp
will be added 10 times to /etc/services and /etc/inetd.conf

2. During installation it adds
 linuxconf 98/tcp
port to /etc/inetd.conf
even if this port was previously commented out in
/etc/inetd.conf.
I recommend to check for linuxconf
port in /etc/inetd.conf first
and if it is commented - not to add it.
The system administrator probably has some good reason
not to open 98 port to the world.

3. During installation linuxconf adds itself
  to /etc/rc.d/rc*/
with 99 number (as S99linuxconf )
This is bad, because rc.local
has the same 99 number.
There TWO services with 99 number:

/etc/rc.d/rc3.d/S99linuxconf
/etc/rc.d/rc3.d/S99local

Same thing in rc2,rc4,rc5.

This creates serious problems in some situations.
Comment 1 Michael K. Johnson 1999-09-20 13:48:59 EDT
The first two are fixed, the last is not a bug.  It is absolutely
acceptable to have two services at any one level, as long as it
does not matter which runs first -- and it doesn't matter which
runs first in this case.
Comment 2 Anonymous 1999-12-25 17:04:59 EST
This bug still exists in current
linuxconf-1.16r10-2
from recent updates.
Multiple entries
are added to /etc/inetd.conf and /etc/services
Comment 3 Michael K. Johnson 2000-01-03 09:40:59 EST
It is most definitely fixed.  I have tested this myself repeatedly.
It will not remove existing duplicate entries, but it will not add
further duplicate entries.
Comment 4 Anonymous 2000-01-04 10:31:59 EST
I do not now.
This is a log on
 uname -a
Linux vladik2 2.2.12-20 #1 Mon Nov 15 15:36:27 EST 1999 i686 unknow
See, one new line is added to
/rtc/services and /etc/inetd.conf
on each
rpm -Uvh --force linuxconf-1.16r10-2.i386.rpm
Vladislav

[root@vladik2 up2date]# grep  linuxconf /etc/inetd.conf
#linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
#linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
[root@vladik2 up2date]#
[root@vladik2 up2date]# rpm -Uvh --force linuxconf-1.16r10-2.i386.rpm
linuxconf                   ##################################################
[root@vladik2 up2date]# grep  linuxconf /etc/inetd.conf
#linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
#linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
[root@vladik2 up2date]#
[root@vladik2 up2date]# grep  linuxconf /etc/services
linuxconf 98/tcp
linuxconf 98/tcp

[root@vladik2 up2date]# rpm -Uvh --force linuxconf-1.16r10-2.i386.rpm
linuxconf                   ##################################################
[root@vladik2 up2date]# grep  linuxconf /etc/services
linuxconf 98/tcp
linuxconf 98/tcp
linuxconf 98/tcp
[root@vladik2 up2date]# grep  linuxconf /etc/inetd.conf
#linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
#linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
[root@vladik2 up2date]#
Comment 5 Michael K. Johnson 2000-01-04 10:47:59 EST
Missed the "commented out" part.  Will fix in the next version.
Comment 6 Nalin Dahyabhai 2000-01-12 09:14:59 EST
The issues with inetd.conf and the services file should be cleared up in
linuxconf-1.16r10-5, which should be in the next Raw Hide.  Please reopen
this bug if it does not solve the problem.

Note You need to log in before you can comment on or make changes to this bug.