This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 491808 - anaconda fights with setup for /etc/hosts file leading to /etc/hosts.rpmnew
anaconda fights with setup for /etc/hosts file leading to /etc/hosts.rpmnew
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-24 01:37 EDT by Jesse Keating
Modified: 2013-01-09 22:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
0001-Do-not-write-etc-hosts-since-setup-owns-that-now.patch (4.14 KB, patch)
2009-03-24 22:39 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description Jesse Keating 2009-03-24 01:37:13 EDT
It looks like, at least with network installs, an /etc/hosts file is written to /mnt/sysimage rather early, which conflicts with the hosts file that comes in the setup package, leading to an immediate /etc/hosts.rpmnew
Comment 1 David Cantrell 2009-03-24 22:38:40 EDT
Have a patch to fix this up now.  Attaching it to this bug report if you want to try it out, but also for my own record keeping.
Comment 2 David Cantrell 2009-03-24 22:39:13 EDT
Created attachment 336579 [details]
0001-Do-not-write-etc-hosts-since-setup-owns-that-now.patch
Comment 3 David Cantrell 2009-03-27 16:34:44 EDT
Fix will be in anaconda-11.5.0.39-1 and later.
Comment 4 Bug Zapper 2009-06-09 08:32:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.