Bug 491811 - compare_providers() not getting it right
compare_providers() not getting it right
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-24 02:15 EDT by Jesse Keating
Modified: 2014-01-21 18:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 17:47:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of yum -d9 install gok (63.15 KB, text/plain)
2009-03-24 02:15 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2009-03-24 02:15:41 EDT
Created attachment 336426 [details]
output of yum -d9 install gok

I don't know how best to summarize but here is the situation.

gok requires gnome-speech
gnome-speech requires festival
festival requires festvox-slt-arctic-hts and festival-voice

Now the problem is that yum when searching for a provider for festival-voice finds a bunch of different voices, once of which is festvox-slt-arctic-hts.  However it decides that the best provider is festvox-kal-diphone and thus selects it, even though it's about to select festvox-slt-arctic-hts as the provider for festvox-slt-arctic-hts.  This leads to an extra voice being installed, and in the case of split media, needing discs 1,2,3,4 and 6.  4 only for that extra voice that is for some reason being selected over festvox-slt-arctic-hts and 6 for another bug I'm tracking.

I've attached output from yum on a simple 'yum install gok' run to illustrate the issue.
Comment 1 seth vidal 2009-03-24 08:26:51 EDT
compare_providers doesn't take into account any other deps when it does its lookup. So two solutions.

since:
Requires: festvox-slt-arctic-hts
and
Requires: festival-voice

is a redundant requirement,

just rebuild festival w/o the second requires.
Comment 2 James Antill 2009-03-24 09:27:25 EDT
Another option is to put a fake version requires on "Requires: festvox-slt-arctic-hts" ... this will make it happen before the "festival-voice" requires, and thus. by the time it gets to the later they'll already be something installed that takes care of it.
Comment 3 Christopher Beland 2009-04-22 15:23:25 EDT
From the changelog, it looks like the dependencies were changed in festival-1.96-11.fc11 in line with the above suggestion.  Is this problem now resolved, or are changes to yum still being requested?
Comment 4 Jesse Keating 2009-04-22 17:47:37 EDT
Things look good here.

Note You need to log in before you can comment on or make changes to this bug.