Bug 491826 - unexpected output from carod with parameter --help
unexpected output from carod with parameter --help
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
low Severity low
: 1.2
: ---
Assigned To: Robert Rati
Martin Kudlej
:
Depends On:
Blocks: 527551
  Show dependency treegraph
 
Reported: 2009-03-24 06:41 EDT by Martin Kudlej
Modified: 2009-12-03 04:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Grid bug fix C: A typographical error was found in the carod source code Running carod from console with parameter --help gave unexpected output: "option --helppidfile requires argument" F: The problem in the code was foudn and resolved R: The command now produces the help text as expected Running carod --help from the shell prompt resulted in an unexpected error stating "option --helppidfile requires argument". This was caused by a typographical error in the carod source code. The error was located and fixed, and the command now produces the help text, as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 04:19:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
comma is missing in carod (213 bytes, patch)
2009-03-24 06:41 EDT, Martin Kudlej
no flags Details | Diff

  None (edit)
Description Martin Kudlej 2009-03-24 06:41:16 EDT
Created attachment 336444 [details]
comma is missing in carod

Version-Release number of selected component (if applicable):
condor-low-latency-1.0-12.el4
condor-low-latency-1.0-12.el5

How reproducible:
Run carod from console with parameter --help

Actual results:
option --helppidfile requires argument

Expected results:
usage: carod [-d|--daemon] [-l|--logdebug] [-h|--help] [-p|--pidfile= <pidfile>]

Additional info:
I added simple patch for carod from condor-low-latency-1.0-12.* as attachment.
Comment 1 Robert Rati 2009-08-17 15:45:21 EDT
Fixed in:
condor-low-latency-1.0-18
Comment 2 Martin Kudlej 2009-09-08 05:13:29 EDT
Tested on Rhel 5 condor-low-latency-1.0-19 and it works-->VERIFIED
Comment 3 Irina Boverman 2009-10-29 10:29:43 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
please see bug summary.
Comment 4 Lana Brindley 2009-11-04 21:35:12 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,8 @@
-please see bug summary.+Grid bug fix
+
+C: A typographical error was found in the carod source code
+Running carod from console with parameter --help gave unexpected output: "option --helppidfile requires argument"
+F: The problem in the code was foudn and resolved
+R: The command now produces the help text as expected
+
+Running carod --help from the shell prompt resulted in an unexpected error stating "option --helppidfile requires argument". This was caused by a typographical error in the carod source code. The error was located and fixed, and the command now produces the help text, as expected.
Comment 6 errata-xmlrpc 2009-12-03 04:19:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1633.html

Note You need to log in before you can comment on or make changes to this bug.