Bug 491926 - perl-5.10.0-54.fc11.i386.rpm is missing CPAN.pm
perl-5.10.0-54.fc11.i386.rpm is missing CPAN.pm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 12:57 EDT by Jim Schneider
Modified: 2009-03-24 13:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 13:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Schneider 2009-03-24 12:57:14 EDT
Description of problem:
The 5.10.0-54.fc11 build of perl 5.10 is missing the CPAN.pm library module.


Version-Release number of selected component (if applicable):
Fedora 11:  /etc/redhat-release contains "Fedora release 10.91 (Rawhide)"
perl 5.10: rpm -q perl gives a result of "perl-5.10.0-54.fc11.i386"

How reproducible:
Always

Steps to Reproduce:
1.  perl -MCPAN -eshell

  
Actual results:
Can't locate CPAN.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/local/lib/perl5/site_perl .).
BEGIN failed--compilation aborted.

Expected results:
This should start the CPAN shell.

Additional info:
Comment 1 Tom "spot" Callaway 2009-03-24 13:40:15 EDT
Not a bug. You need to install the perl-CPAN package. Alternately, if you want to install all of the "core" perl modules at once, you can yum install perl-core.

Note You need to log in before you can comment on or make changes to this bug.