Bug 491928 - NFS over GFS issue (fatal: assertion "!bd->bd_pinned && !buffer_busy(bh)" failed)
NFS over GFS issue (fatal: assertion "!bd->bd_pinned && !buffer_busy(bh)" fai...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: GFS-kernel (Show other bugs)
4
All Linux
urgent Severity high
: ---
: ---
Assigned To: Robert Peterson
Cluster QE
: ZStream
Depends On: 455696
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 12:59 EDT by Benjamin Kahn
Modified: 2010-01-11 22:22 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 04:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2009-03-24 12:59:32 EDT
This bug has been copied from bug #455696 and has been proposed
to be backported to 4.7 z-stream (EUS).
Comment 3 Chris Feist 2009-03-24 15:09:14 EDT
Built in GFS-kernel-2.6.9-80.9.el4_7.14
Comment 5 Robert Peterson 2009-03-26 18:59:28 EDT
I hit a problem and am investigating.  I suspect the patch caused
the problem, so I'm changing the status to FAILS_QA until I can
resolve it.
Comment 6 Robert Peterson 2009-03-27 11:57:03 EDT
The aforementioned problem turned out to be caused by a small section
of code that I had removed with the patch.  I've pushed an addendum
patch that adds the code back in, and the problem is now fixed.
Therefore, I'm changing the status back to Modified.
Comment 7 Chris Feist 2009-04-08 11:21:42 EDT
This fix is built into GFS-kernel-2.6.9-80.9.el4_7.15
Comment 8 Chris Feist 2009-04-20 16:10:54 EDT
Updated packages have been built with another fix:
GFS-kernel-2.6.9-80.9.el4_7.17
Comment 12 errata-xmlrpc 2009-04-28 04:54:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0450.html

Note You need to log in before you can comment on or make changes to this bug.