Bug 49193 - Can not login into a tcsh account
Can not login into a tcsh account
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-07-16 15:18 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-17 04:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-16 15:18:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I have upgraded OS from RH 7.0 to RH 7.1 and after that I could not login 
into my account with tcsh. Only when I changed to bash login worked. Then 
I did a clean installation and even reformatted my disk. The tcsh did not 
As a quick fix I took tcsh from RH 6.2 and put it into /bin directory.
That worked for some time but after I reboot the system tcsh stopped 
working. Then I installed tcsh from RH 7.0 using rpm. That did not work 
either. I am running DELL presision 620 workstation with two cpu's. This 
is a dual boot system with Windows 2000 and Linux. The system is bootable 
from Lilo.

How reproducible:

Steps to Reproduce:
1.Login as a root and using linuxconf change user account to tcsh .
2.Logout and then login again into the account with tcsh.

Actual Results:  Afer typing login name and password the screen goes dark 
for a second and then login screen comes back.

Expected Results:  login into user account through the starx interface

Additional info:

When I open a new window using tcsh account with a tcsh from RH 6.2 OS a 
message shows up:"MANPATH environment variable is not set"
I also talked to other RH 7.1 users and they said that tcsh worked for 
them. May be this problem is an indication of something else going wrong.
Comment 1 Need Real Name 2001-07-26 19:40:45 EDT
I am still waiting for a responce on the problem with tcsh. The shell can be 
changed by typing "tcsh". That does not give all the capabilities of the tcsh. 
It does not give me history for example. I also tried to chsh command 
and /bin/tcsh. That did not work and later on I could not login into that 
shell. The only thing that worked was a copy of tcsh from Red Hat 6.2. This 
worked for the current login session and stoped working after that.
Comment 2 Need Real Name 2001-08-08 15:17:28 EDT
I noticed this exact same problem... I was just going to report it...
i.e., if I change the login shell to tcsh (using chsh for example),
then after logging out of the account I can not log back in from the terminal
(I can, however, ssh to the account...):
I type in the username and password, the screen blinks and
the login screen reappears...

Comment 3 Eido Inoue 2001-08-14 19:15:38 EDT
I tried to reproduce your problem by:

1. installing 7.0 Workstation US (all defaults) clean on a machine with one user
acct and starting in text mode
2. logining into that account, using chsh to change from /bin/bash to /bin/tcsh
3. typing startx to confirm that X and GNOME come up
4. reboot and install 7.1 U.S. via Upgrade
5. login to user acct. tcsh comes up. startx works. gnome-terminal works.

do you have a .xsession-errors or other error messages that appear when you log
into the tcsh acct from the console?
Comment 4 Need Real Name 2001-08-20 11:58:41 EDT
The .xsession-errors file has been sent for a review to havill@redhat.com and to
Comment 5 Tomasz Kepczynski 2002-10-04 07:24:32 EDT
Check if you have /bin/tcsh in /etc/shells... If not - add it, and check if you
can login.
/bin/tcsh disappeared from /etc/shells in one of the previous distributions for
unknown reason and at least it prevented users with tcsh shell from accessing
their accounts using ftp.
Comment 6 francois-xavier bois 2003-01-27 06:32:16 EST
I have the same bug with RHAS
I installed it and then run :
usermod -s /bin/tcsh root

Then when I try to log, I have this 
root: Command not found.
root: Undefined variable.
[root@rhas ~]$

So I have to launch it by hand 
Comment 7 Miloslav Trmač 2004-08-18 10:34:27 EDT
I can't reproduce either behavior.
If it still occurs for you, please attach at least:
* /etc/shells
* whether "/bin/tcsh -l" works
* Output of strace for the attempt to log in:
  use (ps -e | grep mingetty), use the TTY field to select
  a process, then (strace -o log -ff -p pid_of_selected_process)
  and send at least the files matching (grep -l exec.*tcsh log*).
  Note that one or more of the files will probably contain your
Comment 8 Miloslav Trmač 2005-04-17 04:12:58 EDT
Please reopen this report if you can reproduce the problem on a recent release
and you can provide the requested data.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.