This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491938 - encrypted /home causes boot to fail, no such file or directory /dev/mapper/luks-BLAH
encrypted /home causes boot to fail, no such file or directory /dev/mapper/lu...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 13:57 EDT by Eric Paris
Modified: 2009-06-25 11:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-03-24 13:57:47 EDT
Install F11 using the images from March 23.
Choose custom partition layout.
I created 4 partitions

/dev/sda1  /boot (ext3)
/sev/sda2  / (ext4)
/dev/sda3  /home (ext4)
/dev/sda5  swap (swap)

For ONLY /home I chose to encrypt that partition.  It ask my password, the installer worked perfectly.

On boot after the installation finished the machine fails to boot and drops to maintenance mode.  It complains that /dev/mapper/luks-BLAH does not exist.

I edited /etc/fstab and removed the line for /home and the machine boots fine (although not /dev/mapper/luks-* is created, I'm not ask for the p-word, nothing like that)
Comment 1 Eric Paris 2009-03-24 14:02:54 EDT
[root@localhost ~]# fdisk -l /dev/sda

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000948c5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          32      256000   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              32        2582    20480000   83  Linux
/dev/sda3            2582        3104     4194304   83  Linux
/dev/sda4            3105       19457   131355472+   5  Extended
/dev/sda5            3105        3627     4194304   83  Linux



[root@localhost ~]# cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Mon Mar 23 15:46:19 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
UUID=09573af8-c35a-46e4-a78f-285a5ae87e46 /boot                   ext3    defaults        1 2
UUID=36e96839-c795-407e-bbc7-f38e7294babc /                       ext4    defaults        1 1
#/dev/mapper/luks-86fe0ce3-dcd1-4558-b60d-712a9bb29286 /home                   ext4    defaults        1 2
UUID=a4732346-b8a8-448a-8cd2-1a3d0a48c529 swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0



[root@localhost ~]# cat /etc/crypttab
luks-86fe0ce3-dcd1-4558-b60d-712a9bb29286 UUID=86fe0ce3-dcd1-4558-b60d-712a9bb29286 none 

[root@localhost ~]# blkid
/dev/sda2: UUID="36e96839-c795-407e-bbc7-f38e7294babc" TYPE="ext4" 
/dev/sda1: UUID="09573af8-c35a-46e4-a78f-285a5ae87e46" TYPE="ext3" SEC_TYPE="ext2" 
/dev/sda3: UUID="86fe0ce3-dcd1-4558-b60d-712a9bb29286" TYPE="crypt_LUKS" 
/dev/sda5: TYPE="swap" UUID="a4732346-b8a8-448a-8cd2-1a3d0a48c529" 
[root@localhost ~]#
Comment 2 Eric Paris 2009-03-24 14:13:02 EDT
So it looks like the problem is actually with /etc/crypttab above.  

when I ran cat /etc/crypttab I would see the result but there would not be a \n at the end.  The next prompt would be on the same line as the output.

I edited /etc/crypttab with vi and found there was a whitespace like character past the end of the line.  I deleted that white space character.

cat /etc/crypttab now has the next prompt on the next line and on boot I was ask for the password for /home.

So it has something to do with the end of the line in /etc/crypttab
Comment 3 Chris Lumens 2009-03-25 10:49:51 EDT
This should be fixed in today's build of anaconda.  Thanks for the bug report.
Comment 4 Bug Zapper 2009-06-09 08:34:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.