Bug 491945 - SwapError: swapon failed for '/dev/sda2'
SwapError: swapon failed for '/dev/sda2'
Status: CLOSED DUPLICATE of bug 491529
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:a09d3ec5fb7eb112f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 14:49 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 14:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (226.04 KB, text/plain)
2009-03-24 14:49 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-24 14:49:33 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/devicelibs/swap.py", line 85, in swapon
    raise SwapError("swapon failed for '%s'" % device)
  File "/tmp/updates/storage/formats/swap.py", line 118, in setup
    swap.swapon(self.device, priority=self.priority)
  File "/tmp/updates/storage/__init__.py", line 1398, in turnOnSwap
    device.format.setup()
  File "/tmp/updates/packages.py", line 193, in turnOnFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda.intf)
  File "/tmp/updates/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/tmp/updates/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
SwapError: swapon failed for '/dev/sda2'
Comment 1 James Laska 2009-03-24 14:49:37 EDT
Created attachment 336522 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-24 14:53:00 EDT

*** This bug has been marked as a duplicate of bug 491529 ***
Comment 3 IBM Bug Proxy 2009-04-30 06:59:02 EDT
While installing Fedora11 Preview, anaconda reported "SwapError: swapon failed".
Below is the produced call trace.

========================
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/swap.py", line 86, in swapon
    raise SwapError("swapon failed for '%s'" % device)
  File "/usr/lib/anaconda/storage/formats/swap.py", line 119, in setup
    swap.swapon(self.device, priority=self.priority)
  File "/usr/lib/anaconda/storage/__init__.py", line 1434, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/packages.py", line 196, in turnOnFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda.intf)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
SwapError: swapon failed for '/dev/sda3'
============================

Machine: P550
CPU type: Power5

Below are the steps I faced this issue.
1. Start the installation with vnc mode
2. select custom partition
3. Create following partition
      a. Prep with 10M (primary partition)
      b. /boot with 500M (primary)
      c. / with 30000M
      d. swap 3000M
4. When next is pressed, anaconda reported the bug

As per https://bugzilla.redhat.com/show_bug.cgi?id=491529#c18
This should be fixed in anaconda-11.5.0.37-1 where as preview has 11.5.0.47

Note You need to log in before you can comment on or make changes to this bug.