Bug 491951 - gfs2_grow will error on growing the GFS2 filesystem
gfs2_grow will error on growing the GFS2 filesystem
Status: CLOSED DUPLICATE of bug 469773
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Robert Peterson
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 15:14 EDT by Shane Bradley
Modified: 2010-01-11 22:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 18:14:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gfs meta data (2.73 MB, application/x-bzip2)
2009-03-24 15:19 EDT, Shane Bradley
no flags Details

  None (edit)
Description Shane Bradley 2009-03-24 15:14:52 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030503 Fedora/3.0.7-1.fc10 Firefox/3.0.7

User has extended a clustered logical volume and is attempting to
grow the gfs2 filesystem that resides on it to take up that new space.
This volume is using 4k blocksize

The sosreport confirms that the space is showing up properly. I
reviewed the steps customer performed and they look correct. However
upon attempting to grow the GFS2 filesytem they get an error:

$ gfs2_grow /edh_gfs2_test1
      Error: The device has grown by less than one Resource Group (RG).
      The device grew by 0MB.  One RG is 255MB for this file system.
      gfs2_grow complete.

It looks like they have updated to gfs2-utils-0.1.53-1.el5_3.1-x86_64
which resolves that gfs2_grow issue in these bzs.

https://bugzilla.redhat.com/show_bug.cgi?id=483527
https://bugzilla.redhat.com/show_bug.cgi?id=469773

$ grep gfs installed-rpms
gfs-utils-0.1.18-1.el5-x86_64
kmod-gfs-0.1.31-3.el5-x86_64
gfs2-utils-0.1.53-1.el5_3.1-x86_64


-------------------------
HARDWARE INFO:
-------------------------
Storage is located on 3PAR DATA (RAID-5 device)
/dev/sdd :VMware  :Virtual disk    :1.0   :           :    19922944
[root@ohedf068 tmp]#

138 IOLUN04                 50002AC016430379 OHEGNE4_COMM         23000005E600B5D0      2:4:3 port

IOLUN04      Base    --- 5699 RW started     0      0    20480


CISCO MDS9509 SAN SWITCH with the following software:
Software
BIOS:      version 1.1.0
loader:    version 1.2(2)
kickstart: version 3.2(2c)
system:    version 3.2(2c)




Reproducible: Always

Steps to Reproduce:
STEPS TO REPRODUCE: For me this only works on non-4k blocksize, but 4k for customer:
1) mkfs.gfs2 -b 2048 ... on a logical volume
2) mount device
3) lvextend the logical volume (customer and I were both adding 2Gb)
4) gfs2_grow device
Actual Results:  
Error thrown:

        Error: The device has grown by less than one Resource Group (RG).
        The device grew by 0MB.  One RG is 255MB for this file system.
        gfs2_grow complete.


Expected Results:  
The gfs2 fs is grown to the correct size.
Comment 2 Shane Bradley 2009-03-24 15:19:17 EDT
Created attachment 336528 [details]
gfs meta data
Comment 3 Robert Peterson 2009-03-30 17:42:45 EDT
With the latest gfs2-utils package, I've been able to successfully
grow the customer's file system from 5GB to 10GB using the customer's
metadata.  All evidence points to this problem being a duplicate of
bug #469773 (which is in Modified state, so the fix hasn't been shipped
yet, but should make the next release).  Unless I see evidence to the
contrary in the next day or so, I'm planning to close this one as a
duplicate of bug #469773.
Comment 4 Robert Peterson 2009-03-31 09:22:00 EDT
I may have recreated the problem by starting with a 2GB file system,
and extending by another 2G.  I got these messages:

Error: The device has grown by less than one Resource Group (RG).
The device grew by 0MB.  One RG is 255MB for this file system.

I'll figure out why it did that today.
Comment 5 Robert Peterson 2009-03-31 10:04:25 EDT
Sorry, a typing mistake caused a false-positive. Please disregard
comment #4.  When done correctly, with the latest gfs2 code that
includes the fix for bug #469733, I had no problem extending and
gfs2_growing a GFS2 file system from 2GB to 4GB.
Comment 6 Robert Peterson 2009-03-31 18:14:09 EDT
I guess there are no objections, so I'm closing this as a duplicate
of bug #469773.  If anyone finds evidence to the contrary, feel free
to reopen this bug record.

*** This bug has been marked as a duplicate of bug 469773 ***

Note You need to log in before you can comment on or make changes to this bug.