This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491967 - Change Listable getResult signature to take the action mapping
Change Listable getResult signature to take the action mapping
Status: CLOSED DEFERRED
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity low
: ---
: ---
Assigned To: Jay Dobies
Red Hat Satellite QA List
:
Depends On:
Blocks: space16
  Show dependency treegraph
 
Reported: 2009-03-24 15:36 EDT by Jay Dobies
Modified: 2011-08-05 08:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-05 08:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2009-03-24 15:36:16 EDT
This BZ is a tracker for enhancing the new list tag implementation. Passing in the action mapping to the getResult method would let us pass in properties to actions that use the tag that dictate the data returned (the action mapping is needed to get the property values).

One use case is the errata pages. I'd like to have one action that handled loading the data for both "all" and "relevant" errata. To determine which to display, a property could be set on the action in the struts-config.xml. Based on the value, the getResult method could decide which data to load for the tag.

Note that this is not needed for any particular release (there are workarounds), rather is just an enhancement to working with the tag.
Comment 1 Jan Pazdziora 2010-11-19 11:04:23 EST
Mass-moving to space13.
Comment 2 Jan Pazdziora 2011-02-28 13:39:07 EST
Jason,

do you have a patch for this bugzilla, or some code to start with?

Thank you,

Jan
Comment 3 Miroslav Suchý 2011-04-11 03:33:01 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 4 Miroslav Suchý 2011-04-11 03:37:00 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 5 Jan Pazdziora 2011-07-20 07:51:10 EDT
Aligning under space16.
Comment 6 Clifford Perry 2011-08-05 08:28:08 EDT
This is not a priority for Red Hat's Spacewalk developers and will likely not be completed by Red Hat in the next 2 years. We agree that this is a valid request and something that could be achieved. Since reporter by developer for improving this sub-system/component of Spacewalk code I am closing this out as DEFERRED. Feel free to re-open if you wish this re-reviewed. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.