Bug 49198 - install using e100 driver
install using e100 driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-16 15:45 EDT by Bryan Leopard
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 15:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-07-16 15:45:45 EDT
Since you won't change the default for us to the e100 driver can you make 
it an option.  Below are the pci codes for our nics.

0x8086 0x1229 0x0e11 0xb02f "e100" "Compaq|NC1120 Ethernet NIC" 
0x8086 0x1229 0x0e11 0xb01e "e100" "Compaq|NC3120 Fast Ethernet NIC" 
0x8086 0x1229 0x0e11 0xb04a "e100" "Compaq|10/100 TX PCI Intel WOL UTP 
Controller"
0x8086 0x1229 0x0e11 0xb0d7 "e100" "Compaq|NC3121 Fast Ethernet NIC" 
0x8086 0x1229 0x0e11 0xb01f "e100" "Compaq|NC3122 Fast Ethernet NIC"
0x8086 0x1229 0x0e11 0xb0dd "e100" "Compaq|NC3131 Fast Ethernet NIC"
0x8086 0x1229 0x0e11 0xb0de "e100" "Compaq|NC3132 Fast Ethernet Module"
0x8086 0x1229 0x0e11 0xb0e1 "e100" "Compaq|NC3133 Fast Ethernet Module" 
0x8086 0x1229 0x0e11 0xb0c7 "e100" "Compaq|NC3160 Fast Ethernet NIC"
0x8086 0x1229 0x0e11 0xb0c6 "e100" "Compaq|NC3161 Fast Ethernet NIC" 
0x8086 0x1229 0x0e11 0xb144 "e100" "Compaq|NC3123 Fast Ethernet NIC"
0x8086 0x1229 0x0e11 0xb163 "e100" "Compaq|NC3134 Fast Ethernet NIC"
0x8086 0x1229 0x0e11 0xb164 "e100" "Compaq|NC3135 Fast Ethernet Upgrade 
Module"
0x8086 0x1229 0x0e11 0xb13c "e100" "Compaq|NC3162 Fast Ethernet NIC"
0x8086 0x1229 0x0e11 0xb134 "e100" "Compaq|NC3163 Fast Ethernet NIC"

0x8086 0x1000 0x0e11 0xb123 "e1000" "Compaq|NC6134 Gigabit NIC"
0x8086 0x1000 0x0e11 0xb0df "e1000" "Compaq|NC6132 Gigabit Module"
0x8086 0x1000 0x0e11 0xb0e0 "e1000" "Compaq|NC6133 Gigabit Module" 
0x8086 0x1001 0x0e11 0x004a "e1000" "Compaq|NC6136 Gigabit Server Adapter"
0x8086 0x1004 0x0e11 0xb1a4 "e1000" "Compaq|NC7131 Gigabit Server Adapter"
0x8086 0x1004 0x0e11 0x0049 "e1000" "Compaq|NC7132 Gigabit Upgrade Module"
Comment 1 Michael Fulbright 2001-07-17 11:47:27 EDT
Matt is this workable with just a driver disk and using the 'noprobe' option to
the installer?
Comment 2 Matt Wilson 2001-07-20 10:07:08 EDT
I don't understand the question.  You should be able to use the e100 module if
the user uses 'noprobe'.  otherwise, do these PCI IDs apply only to your cards? 
With your choice of the e100 module, are you indemnifying from having to fix
problems that using the e100 module will cause?
Comment 3 Bryan Leopard 2001-07-30 15:23:19 EDT
It is true that the user can reconfigure to use the e100 driver.  The request 
is that the installation default to the e100 rather than the eepro100 at least 
for Compaq Intel based NICs.  Compaq engineering feels that it is a more 
reliable driver and that it is better supported since it is an Intel driver and 
has considerable more testing on that driver here at Compaq.
Comment 4 Michael Fulbright 2001-08-01 15:02:43 EDT
Reassigning to 'distribution' component. Default driver selection is not handled
by the installer, but kudzu.
Comment 5 Bill Nottingham 2001-08-01 15:05:13 EDT
Um, no. We've answered this before.
Comment 6 Michael K. Johnson 2001-08-01 15:25:51 EDT
I'd like to know what extensive technical analysis Compaq has done to
come up with this idea.  Has your team of crack network device driver
writers audited the source code?  When they did the audit, did they
happen to notice the half second busy-wait with IRQs disabled that
 1) may damage their own P4 processor, and
 2) may cause data loss by confusing the SCSI subsystem?
Have they tried to fix a bug in the driver?

The current question is not whether the e100 driver will become the
default, but whether it will even continue to be part of the
distribution.  Intel is working on changing the driver to fix bugs
enough that we can continue to include it in the distribution.
Their current driver revision has introduced bugs that not only
make the driver even less maintainable than it was before, but also
threaten data integrity.  (Not to mention that the source code for
the e100 driver is unnecessarily an *order of magnitude* larger than
the eepro100 driver and the source code is harder to read -- the
e100 driver is larger than some entire operating systems...)  We
could go into all the problems with the e100 driver, but we'd rather
do that with Intel directly and help them improve their driver
instead, and we are in the process of doing precisely that.

But we will not be making this driver the default in the forseeable
future.

Please do not continue to open bug reports regarding this behavior.
Thank you for your future cooperation in this matter.

Note You need to log in before you can comment on or make changes to this bug.