This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492008 - Add requires for mtools to allow changing of FAT filesystem labels?
Add requires for mtools to allow changing of FAT filesystem labels?
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 18:45 EDT by Orion Poplawski
Modified: 2009-03-25 10:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 10:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-03-24 18:45:10 EDT
Description of problem:

gparted currently needs mtools to change FAT filesystem labels.  Probably worth a Requires.  Also filed upstream bug requesting support to use dosfstools' dosfslabel.  May want to switch to that when it happens.

http://bugzilla.gnome.org/show_bug.cgi?id=576616
Comment 1 Deji Akingunola 2009-03-25 10:17:19 EDT
I'm not inclined to add a requires for mtools for gparted. The reason being that gparted support quite a (small) number of filesystems, for which it does a runtime detection of the various tools filesystems tools. I think it is superfluous to add all these as require for the package.
I believe your suggestion to upstream to use dosftools is a good one, as it seems to be install by default.

Note You need to log in before you can comment on or make changes to this bug.