Bug 492009 - network retry exits
network retry exits
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 18:50 EDT by Ray Todd Stevens
Modified: 2009-05-05 15:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 15:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2009-03-24 18:50:19 EDT
This is a problem with doing a preupgrade where the boot partition is to small.   

#1   Sooner or later you really need to get static ips supported.

#2   MOre impoirtant it you don't have the wiring rewired exactly properly to now support dhcp then the section about aquiring a network address fails.   It asks you if you want to retry, and then return reboots, and reboots back to the old OS.   Retry should retry.
Comment 1 David Cantrell 2009-03-24 20:28:27 EDT
Is there any way you can describe the specific problem you're seeing and provide a reproducer?
Comment 2 Ray Todd Stevens 2009-03-24 20:52:14 EDT
Well I am not entirely sure what you are asking.   I will try to give more detailed instructions to get in trouble here.   Lets leave #1 out of this for the time being, but be aware that machines with static ips don't work well with preupgrade if you have to download the image files.   But that is a seperate issues.   Lets get to issue #2 and creating it.

First setup a fc10 machine with a boot partition small enough so that preupgrade can't load the image file and has to do this as  a part of the upgrade.

Second don't plug the network cable in.   (I plugged in the wrong cable to the hub).

third reboot and start the upgrade.

Since it has to download the image file it says that network manager is configuring the eth0 card.  It will only do dhcp and not static so it has to find a dhcp server to do the configuration.    Since the cable is unplugged it can't do this.   It gives you an error message and asks if you want to retry.

"Find the problem" and plug the cable in.

Select the retry option

The system now goes to the shutdown mode and halts with that message that you can now reboot the server.

It should have retried the dhcp but doesn't

The  when you reboot it goes into a normal reboot, which I guess is OK.   But once we go production it would be nice to have these upgrades that fail ask if you want to boot back to a retry of the upgrade or back to the OS.   But the is more of an RFE.

The real issue is that the retry doesn't retry.

Does this help?
Comment 3 Ray Todd Stevens 2009-03-26 15:33:16 EDT
I wonder if this is related to bug 476372 reported on last release?
Comment 4 David Cantrell 2009-05-05 15:38:13 EDT
Fixed in anaconda-11.5.0.50-1.fc11 and later.

Note You need to log in before you can comment on or make changes to this bug.