Bug 492013 - Revert to opensync 0.22
Revert to opensync 0.22
Product: Fedora
Classification: Fedora
Component: libopensync (Show other bugs)
All Linux
urgent Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
Blocks: F11Target
  Show dependency treegraph
Reported: 2009-03-24 19:17 EDT by Adam Williamson
Modified: 2009-07-29 18:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-29 18:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2009-03-24 19:17:57 EDT
As discussed and generally agreed on -devel-list in recent days, opensync 0.36 (and the newest available version, 0.38) is useless for practical purposes. This is also the position of upstream, which expressly discourages distributions from packaging 0.3 series releases.

Therefore we should revert all opensync packages to their 0.22 versions in time for Fedora 11's release. Andreas has already built testing packages for this purpose at http://fedora.lowlatency.de/opensync-synce/ - SRPMs are available there. I have tested that these packages both replace the current Rawhide packages smoothly, and actually work (I have working synchronization with a Windows Mobile device via the synce packages also available in that repository).

Andreas may be able to take care of this soon, otherwise we may need provenpackagers to do it.
Comment 1 Andreas Bierfert 2009-03-25 07:50:21 EDT
Back online again :D

Will start rolling out packages to rawhide in the next hours.
Comment 2 Adam Williamson 2009-03-25 08:11:53 EDT
awesome, thanks andreas!

just a reminder that I sent some follow-up emails with some suggested tweaks for the synce packages too :)

Fedora Bugzappers volunteer triage team
Comment 3 Felix Kaechele 2009-03-26 05:58:29 EDT
Is there any action required from me, as the libsyncml maintainer?
Comment 4 Adam Williamson 2009-03-26 11:08:56 EDT
felix: yes - ideally we'd need that to be downgraded to 0.4.6, which is the last version you can build the opensync 0.22 syncml plugin with.

Fedora Bugzappers volunteer triage team
Comment 5 Andreas Bierfert 2009-03-27 15:59:40 EDT
Ok everything is out except for the syncml plugin.
Comment 6 Alex Lancaster 2009-03-31 17:55:08 EDT
Is anybody actively working on porting these broken deps in rawhide to
the newly downgraded opensync?

Broken deps for i386
        libopensync-plugin-kdepim-0.36-2.fc11.i586 requires libopensync.so.1
        libopensync-plugin-syncml-0.35-4.fc10.i386 requires libsyncml.so.0
        libopensync-plugin-syncml-0.35-4.fc10.i386 requires libopensync.so.1
        libopensync-plugin-vformat-0.36-2.fc11.i586 requires libopensync.so.1

If you could point me to a bugzilla bug, that would be great.  If nobody such as the primary maintainer of these packages are actively working on it, I'll try to look into it.
Comment 7 Felix Kaechele 2009-03-31 18:08:35 EDT
A downgraded libsyncml (0.4.6) is now in rawhide. But still libopensync-plugin-syncml fails in koji.
See http://koji.fedoraproject.org/koji/taskinfo?taskID=1268772
Comment 8 Alex Lancaster 2009-03-31 19:02:50 EDT
It seems that 0.36 has failed to build on *any* branch such as F-9 or F-10:


I suspect that we might need to back out to 0.35 as 0.36 seems to have trouble building even against the old opensync stack.

In addition, looking at the spec:


it appears that there has been no Epoch tag added.  If there was ever a successful build of 0.38 that existing in rawhide, it should be added, if not, I guess it isn't strictly speaking, necessary.
Comment 9 Adam Williamson 2009-03-31 19:09:20 EDT
We need to build version 0.22 of the plugin. opensync plugins must be of the same version as the main part of opensync. A 0.3 plugin cannot work on opensync 0.22. Please just downgrade the plugin to 0.22 and it should work right off the bat.
Comment 10 Alex Lancaster 2009-03-31 19:09:51 EDT
I see you backgraded even further to 0.22:


but since 0.35 *did* exist in rawhide at one point because of a successful koji build in F-10 which F-11 would have got by inheritance you still the Epoch tag

Also 0.35 exists as an update in F-10 and F-9:


so this update needs further co-ordination and discussion.
Comment 11 Alex Lancaster 2009-03-31 19:13:05 EDT
See also:

Comment 12 Alex Lancaster 2009-03-31 19:16:10 EDT
This is the current build that exists in both F-10 GA and in all F-11 versions:


so if we really need to backgrade all the plugins to 0.22 this will require a wholesale distro bump across all branches.  

I don't understand why 0.35 was ever pushed.  Did it ever work?

This is a real mess.
Comment 13 Alex Lancaster 2009-03-31 19:19:02 EDT
If somebody could summarize the entire situation and status with all the opensync-related packages.  Perhaps including a table of package name, versions, builds of the main stack and all the plugins on all branches that would be very helpful.

It looks like there will need to be a lot of Epoch tags added and new updates pushed on F-9 and F-10 to make this all go smoothly.
Comment 14 Adam Williamson 2009-04-01 11:43:33 EDT
I wasn't really worrying about F-9 or F-10, just wanted to have a useful version going forwards from F-11.

FWIW, though, in *theory*, what you need is to have all packages for any given release of the same version - 0.22, or 0.35, or 0.36, or 0.38. You can't mix any of those.

In *practice*, if you want opensync to actually work at all, you want them all to be 0.22, because that's the only version that works. But if F-9 or F-10 have all 0.36 packages (or all 0.35 or all 0.38), then that's a conherent opensync codebase, just one that doesn't happen to be of any particular practical use to anyone at all...

if they have a mix, then only plugins that are of the same version as the base 'libopensync' package are likely to 'work'.
Comment 15 Alex Lancaster 2009-04-01 11:57:03 EDT
(In reply to comment #14)
> I wasn't really worrying about F-9 or F-10, just wanted to have a useful
> version going forwards from F-11.

But even in terms of F-11, you still need to have appropriate Epoch: tags added to each downgraded package plugin package otherwise you'll break the upgrade path from F-10 -> F-11 as it will refuse the install tne old 0.22 because: 0.36 > 0.22.
Comment 16 Adam Williamson 2009-04-01 12:33:21 EDT
yes, I know that (I did the downgrade for Mandriva, lots of fun that was...). I figured that was for the packager to sort out :)

epoch tag plus correct obsoletes are the way to go, i think.

And no, no 0.3x release has ever actually worked for practical synchronization purposes. It was only ever pushed because KDE 4 'required' it (for kitchensync, a GUI sync front end) to build for a while. Apparently no-one at KDE or Fedora ever bothered to check whether you could actually do any synchronization with it.
Comment 17 Andreas Bierfert 2009-04-01 12:40:21 EDT
I can only speak for the plugins I touched for F-11 but imho upgrades from F-{9,10} should go smoothly. Fitting obsoletes and epoch bumps were added where necessary. Of course an epoch bump is also needed for the syncml plugin. vformat and kdepim can be blocked from dist-f11 dependencies will be satisfied by libopensync.
Comment 18 Juha Tuomala 2009-04-01 17:32:30 EDT
(In reply to comment #16)
> It was only ever pushed because KDE 4 'required' it (for kitchensync,
> a GUI sync front end) to build for a while. 

No, those are developer snapshots meant for plugin devs to catch up and testers to have reference point but that never worked really like supposed. Most plug devs just lost the pace with api.

> Apparently no-one at KDE or Fedora ever bothered to check whether you 
> could actually do any synchronization with it.  

Among other things. All epochs well earned.
Comment 19 Adam Williamson 2009-04-13 12:44:42 EDT
Andreas, I've sent several emails with further tweaks that are needed for the packages (opensync and synce) to work fully - have you not received them? I just want to make sure everything's in there in good time for F11. Thanks.

Fedora Bugzappers volunteer triage team
Comment 20 Bill McGonigle 2009-05-12 21:07:27 EDT
All the packages from lowlatency.de build on f10 except for libopensync-plugin-evolution2.  Build dies here:

/usr/include/evolution-data-server-2.24/libical/ical.h:30:2: error: #warning "Please ensure that the memory returned by the functions mentioned at http://bugzilla.gnome.org/show_bug.cgi?id=516408#c1 are free'ed"

multisync might need a BuildRequires:

Checking for package osengine-1.0 >= 0.19           : not found
you need opensync http://www.opensync.org/ (libopensync0-dev)
 (error raised in module wscript_main)
error: Bad exit status from /var/tmp/rpm-tmp.vx9PlE (%build)

After building and installing that package it builds fine.

I'm assuming shipping an inappropriate opensync on f10 is worth fixing too.
Comment 21 Bug Zapper 2009-06-09 08:36:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 22 Adam Williamson 2009-07-29 18:28:23 EDT
I think we may as well close this bug now, the work was done. I'll file separate bugs for any remaining issues.

Fedora Bugzappers volunteer triage team

Note You need to log in before you can comment on or make changes to this bug.