Bug 492025 - Absolute links prevent forward proxies
Absolute links prevent forward proxies
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ktorrent (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 20:11 EDT by Arthur Pemberton
Modified: 2009-05-30 21:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-30 21:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 188134 None None None Never

  None (edit)
Description Arthur Pemberton 2009-03-24 20:11:25 EDT
Description of problem:
Can't forward proxy KTorrent site from a sub-folder path because login form posts to /login

How reproducible:
100%

Steps to Reproduce:
1. Enable Ktorrent Web Interface
2. Setup proxy to http://ktorrenthost:port/ from http://accessible.tld/foobar/
3. Browse to http://accessible.tld/foobar/
4. Attempt to log in
  
Actual results:
Form posts to /login, login fails.

Expected results:
Form posts to login and login succeeds.

Additional info:
Either using relative URLs through out or allowing the user to choose a path will work.
Comment 1 Arthur Pemberton 2009-05-20 22:42:35 EDT
This problem still exists in ktorrent-3.2.1-1
Comment 2 Steven M. Parrish 2009-05-30 21:41:55 EDT
Thanks for reporting this issue upstream.  The upstream report indicates this issue has been resolved and should appear in a future release.

Note You need to log in before you can comment on or make changes to this bug.