Bug 492120 - Add shared-mime-info
Add shared-mime-info
Status: CLOSED WONTFIX
Product: Fedora Localization
Classification: Fedora
Component: l10n-requests (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Dimitris Glezos
A S Alam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 09:30 EDT by Bastien Nocera
Modified: 2013-07-02 20:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 09:13:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 20895 None None None Never

  None (edit)
Description Bastien Nocera 2009-03-25 09:30:20 EDT
Currently, shared-mime-info is using the "Translation Project", but it requires too much manual intervention to be useful (pot files need to be sent via mail, and updating translations from the project needs manual download as well)

    *  Module name
shared-mime-info

    * Description
freedesktop.org shared MIME info database

    * Project webpage
http://freedesktop.org/wiki/Software/shared-mime-info

    * VCS root, Module, Branch
:ext:cvs.freedesktop.org:/cvs/mime/
module is shared-mime-info
branch is HEAD

    * Web front-end to VCS
http://webcvs.freedesktop.org/mime/shared-mime-info/

    * File filter (eg. '.*/po/.*')
Same

    * Translations' changelog file (if applicable)
po/ChangeLog

new languages should be listed in po/LINGUAS

    * Contact point (name, email, role in project)

myself, upstream maintainer
CC:'ing some fd.o admins to this bug as well
Comment 1 Piotr Drąg 2009-03-25 15:23:50 EDT
Added to Transifex:

https://translate.fedoraproject.org/tx/projects/shared-mime-info/
https://translate.fedoraproject.org/tx/projects/shared-mime-info/HEAD/

But are you sure CVS root you provided is valid? It doesn't work, and I'm sure it does not allow to commit stuff.
Comment 2 Bastien Nocera 2009-03-26 17:35:43 EDT
(In reply to comment #1)
<snip>
> But are you sure CVS root you provided is valid? It doesn't work, and I'm sure
> it does not allow to commit stuff.  

Well, the CVS root is missing a username, and I most likely need to create a request on fd.o to get "transifex" an account.
Comment 3 Bastien Nocera 2009-03-26 18:51:11 EDT
I've got to go through the admin, so the account requests are:
http://www.freedesktop.org/wiki/AccountRequests

Where they'd need a private ssh key as well as a GPG key to be able to add the new account.

The bugzilla is already opened at:
http://bugs.freedesktop.org/show_bug.cgi?id=20895
Comment 4 Piotr Drąg 2009-06-13 00:16:19 EDT
Dimitris, could you take a look at fd.o bug #20895?
Comment 5 Piotr Drąg 2009-07-03 16:08:21 EDT
Mass change of component from Transifex to Website, since all our websites are handled by Transifex now.
Comment 6 Piotr Drąg 2009-10-01 09:02:23 EDT
I've seen request to add this project to transifex.net, so you are not going to use Fedora-specific instance anymore? It would probably be a good decision not to use both. Additionally, I've heard of some technical problems with connecting Fedora's Transifex to freedesktop's CVS, which were blocking us here. Hopefully it's not the case with transifex.net.
Comment 7 Bastien Nocera 2009-10-01 09:10:33 EDT
(In reply to comment #6)
> I've seen request to add this project to transifex.net, so you are not going to
> use Fedora-specific instance anymore? It would probably be a good decision not
> to use both. Additionally, I've heard of some technical problems with
> connecting Fedora's Transifex to freedesktop's CVS, which were blocking us
> here. Hopefully it's not the case with transifex.net.  

Well, we had the same problem with Transifex.net, but we're getting that sorted.

I was told by the guys on #transifex that it was better and easier to have upstream projects be on transifex.net rather than distro specific instances.

I guess you can close this bug once you've undone any work that was already in place on the Fedora transifex instance.

Thanks for your patience
Comment 8 Piotr Drąg 2009-10-01 09:13:18 EDT
Thank you.

Note You need to log in before you can comment on or make changes to this bug.