Bug 492126 - installer does not ask if I want to install non-Satellite packages (uninstalled prerequisites)
installer does not ask if I want to install non-Satellite packages (uninstall...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Jan Hutař
: Regression
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-03-25 09:54 EDT by Jan Hutař
Modified: 2009-08-05 10:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 08:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-03-25 09:54:20 EDT
Description of problem:
Installer do not asks if I want to install packages - it installs them without asking. I'm not sure if this is expected, as I belive, older releases needed "--run-updater".


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090323.0-x86_64


How reproducible:
always


Steps to Reproduce:
1. # ./install.pl


Actual results:
* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: System is already registered with RHN.  Not re-registering.
* Checking for uninstalled prerequisites.
* Applying updates.
* Installing RHN packages.
 ;@_
[...]


Expected results:
Question if I want to install packages automatically.


Additional info:
What is expected behaviour here?
Comment 1 Brandon Perkins 2009-03-26 12:41:30 EDT
I'm assuming there was no answers file used here.  If there was, we need to see it, otherwise, it looks like a regression.
Comment 2 Jan Hutař 2009-03-31 07:23:22 EDT
Yes, it was without answer file.

Note: I have just tested Satellite-5.3.0-RHEL4-re20090327.0 on RHEL4 and it correctly asks:

[...]
** Checking if up2date is available ...
We can try to install the needed packages now, by running up2date -i.
Do you want to run this command now [y/N]?
[...]
Comment 3 Jan Hutař 2009-04-01 08:06:03 EDT
OK, also tested Satellite-5.3.0-RHEL5-re20090327.0/s390x on RHEL5 and seems to be fixed, sorry for the mess.
Comment 4 Sayli Karmarkar 2009-08-05 10:52:49 EDT
Also on rhel5: 

There are some packages from Red Hat Enterprise Linux that are not part
of the @base group that Satellite will require to be installed on this
system. The installer will try resolve the dependencies automatically.
However, you may want to install these prerequisites manually.
Do you want the installer to resolve dependencies [y/N]? y

ClosedValid

Note You need to log in before you can comment on or make changes to this bug.