Bug 492137 - ks, ise in webui initiating a guest kickstart
ks, ise in webui initiating a guest kickstart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Mike McCune
wes hayutin
http://grandprix.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-03-25 11:08 EDT by wes hayutin
Modified: 2009-09-10 15:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tomcat log (14.72 KB, application/octet-stream)
2009-03-25 11:08 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-25 11:08:58 EDT
Created attachment 336657 [details]
tomcat log

Description of problem:
Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso

ks, x86_64 guest on x86_64 host, ISE in webui initiating ks

recreate:
1. register a x86_64 pv host, give entitlements etc..
2. create an x86_64 guest ks profile
3. try to kickstart a x86_64 guest

get ISE..
see attached log
Comment 1 wes hayutin 2009-03-25 11:11:20 EDT
recreated w/ x86.. changing title of bug
Comment 2 wes hayutin 2009-03-25 11:19:59 EDT
From: RHN Satellite <dev-null@redhat.com>
To: whayutin@redhat.com
Date: Wed, 25 Mar 2009 11:10:35 -0400
Subject: WEB TRACEBACK from grandprix.rhndev.redhat.com (3/25/09 11:10:35 AM EDT)
The following exception occurred while executing this request:
POST /rhn/systems/details/virtualization/ProvisionVirtualizationWizard.do

Date:3/25/09 11:10:35 AM EDT
Headers:
 host: grandprix.rhndev.redhat.com
 user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
 accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
 accept-language: en-us,en;q=0.5
 accept-encoding: gzip,deflate
 accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
 Keep-Alive: 300
 connection: keep-alive
 referer: http://grandprix.rhndev.redhat.com/rhn/systems/details/virtualization/ProvisionVirtualizationWizard.do?sid=1000010060
 cookie: JSESSIONID=1C4B7847D42FBFBE5FF6AE98630BD12A; rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|49BD59C500003C34-A3A0961000080B9[CE]; __qca=1237146063-20184992-47498182; pxt-session-cookie=123x4871f6220efc7ea1fa00bb772d7cdb4b
 content-type: application/x-www-form-urlencoded
 content-length: 568

Request:
Local Name = grandprix.rhndev.redhat.com
Server Name = grandprix.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@18711871[session=StandardSession[1C4B7847D42FBFBE5FF6AE98630BD12A]]
Protocol = http
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, __sitemesh__filterapplied, kickstartScheduleWizardForm, org.apache.struts.action.MESSAGE, session, org.apache.struts.action.mapping.instance, profile, requestedUri, org.apache.struts.action.MODULE,

Form Variables:
 date_year: 2009
 next_lower: 3
 prev_filter_value:
 sid: 1000010060
 last_lower: 1
 virtBridge:
 localStorageMegabytes:
 guestName:
 memoryAllocation:
 first_lower: 1
 items_selected: MTIzNzk4OTk0NC41OTc0MjgyNzMuODEyNzM
 date_month: 2
 targetProfile:
 virtualCpus:
 prev_lower: 1
 items_on_page: MTIzNzk5MDAwOS41MjY3MTkzNjkuOTU1Njg
 wizardStep: third
 diskPath:
 date_minute: 9
 date_day: 25
 cobbler_id: MTIzNzk5MDAwOS41MjY3MTkzNjkuOTU1Njg
 kernelParams:
 targetProfileType:
 filter_string:
 scheduleAsap: true
 date_hour: 11
 proxyHost:
 lower: 1
 date_am_pm: 0


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException
       at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
       at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
       at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
       at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
       at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
       at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
       at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
       at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
       at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
       at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
       at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
       at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
       at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
       at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
       at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
       at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
       at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
       at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
       at java.lang.Thread.run(Thread.java:735)
Caused by: java.lang.reflect.InvocationTargetException
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
       at java.lang.reflect.Method.invoke(Method.java:599)
       at com.redhat.rhn.frontend.struts.wizard.WizardStep.invoke(WizardStep.java:116)
       at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.dispatch(RhnWizardAction.java:104)
       at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.execute(RhnWizardAction.java:90)
       at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
       ... 40 more
Caused by: java.lang.NullPointerException
       at com.redhat.rhn.manager.kickstart.cobbler.CobblerSystemCreateCommand.store(CobblerSystemCreateCommand.java:223)
       at com.redhat.rhn.manager.kickstart.KickstartScheduleCommand.store(KickstartScheduleCommand.java:587)
       at com.redhat.rhn.frontend.action.systems.virtualization.ProvisionVirtualizationWizardAction.runThird(ProvisionVirtualizationWizardAction.java:192)
       ... 48 more
Comment 3 wes hayutin 2009-05-11 09:45:26 EDT
verified working on 5/7.1 build
Comment 4 Steve Salevan 2009-07-31 17:31:10 EDT
RELEASE_PENDING on 7/24 build.
Comment 5 Brandon Perkins 2009-09-10 15:24:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.