Bug 49215 - beta2 autopartitioner doesn't give enough swap
beta2 autopartitioner doesn't give enough swap
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-16 21:25 EDT by Sam Varshavchik
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 12:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2001-07-16 21:25:07 EDT
beta2 autopartitioner proposed the following layout, when I chose to get
rid of all existing Linux partitions on a dual-boot laptop with 80mb ram:

hda1   515M existing fat32
hda2  2417M extended partition
  hda5 515M existing fat32

  hda6   51M ext3 /boot
  hda7 1823M ext3 /
  hda8   27M swap

Freespace  3M

Freespace is due to the fact that the extended partition appears to be one
cylinder short of the reported disk size, so there's a spare 1 cylinder at
the tail end of the disk.

Anyway, this laptop has 80MB of RAM, so kernel 2.4 will need at least 160mb
swap.
Comment 1 Glen Foster 2001-07-17 14:59:59 EDT
This defect considered SHOULD-FIX for Fairfax gold-release.
Comment 2 Michael Fulbright 2001-07-24 00:33:46 EDT
Which install type did you choose (Workstation, Laptop, etc)?
Comment 3 Sam Varshavchik 2001-07-24 01:09:04 EDT
laptop install on a laptop.  http install using pcmcia.img

told the installer to autopartition, and to remove all existing linux partitions.



Comment 4 Michael Fulbright 2001-07-25 17:32:33 EDT
We have fixed something which should help you on this issue. Please retry when
Beta 3 is out and let us know how it works.
Comment 5 Sam Varshavchik 2001-07-30 12:54:00 EDT
In beta3, autopartitioning now selects 1748Mb for /, and 102Mb for swap (/boot
remained the same).  That's better than 27Mb, but the laptop has 80Mb RAM.

Comment 6 Michael Fulbright 2001-08-01 11:51:39 EDT
This sounds like the proper behavior - we try to allocate between RAM to 2*RAM
of swap, starting at RAM and growing upwards.  You can manually edit the swap
request on the partitioning screen if you would like greater control over its size.

Note You need to log in before you can comment on or make changes to this bug.