Bug 492155 - octave's function glpk broken due to "undefined symbol: _glp_lib_fault_hook"
octave's function glpk broken due to "undefined symbol: _glp_lib_fault_hook"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 12:42 EDT by Jaak Simm
Modified: 2009-11-04 13:23 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.2.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 07:25:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaak Simm 2009-03-25 12:42:30 EDT
Description of problem:

Octave function glpk is broken, due to undefined symbol.

Version-Release number of selected component (if applicable):
octave-3.0.3-1.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. run octave
2. write:
   glpk([1],[1],[0])
3. press enter
  
Actual results:
octave:1> glpk([1],[1],[0])
octave: symbol lookup error: /usr/libexec/octave/3.0.3/oct/i386-redhat-linux-gnu/__glpk__.oct: undefined symbol: _glp_lib_fault_hook

Expected results:
Function output.

Additional info:
Similar bug was found in the build of Debian's octave package and they have fixed it.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514035
Comment 1 Alex Lancaster 2009-09-07 01:36:32 EDT
I can reproduce this on F-11:  octave-3.0.5-1.fc11.x86_64

> glpk([1],[1],[0])
octave: symbol lookup error: /usr/libexec/octave/3.0.5/oct/x86_64-redhat-linux-gnu/__glpk__.oct: undefined symbol: _glp_lib_fault_hook

This may be fixed by octave 3.2 but it will be a while before that is backported to F-11, probably.  I'll look into how Debian fixed it.
Comment 2 Rakesh Pandit 2009-09-24 03:16:46 EDT
I can also reproduce it on F10 and F11

octave:1> glpk([1],[1],[0])
octave: symbol lookup error: /usr/libexec/octave/3.0.3/oct/i386-redhat-linux-gnu/__glpk__.oct: undefined symbol: _glp_lib_fault_hook

Will check with importing the patch or looking around ..

Thanks,
Comment 3 Fedora Update System 2009-10-19 20:07:47 EDT
plplot-5.9.5-1.fc11,pfstools-1.7.0-8.fc11,GMT-4.5.0-4.fc11,octave-forge-20090607-15.fc11,octave-3.2.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/plplot-5.9.5-1.fc11,pfstools-1.7.0-8.fc11,GMT-4.5.0-4.fc11,octave-forge-20090607-15.fc11,octave-3.2.3-1.fc11
Comment 4 Jaak Simm 2009-10-23 11:11:15 EDT
Tried the update and octave-3.2.3-1.fc11 fixes this bug.
Comment 5 Alex Lancaster 2009-10-27 17:13:15 EDT
Fixes it for me too.  Can you visit the bodhi update:

http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10548

login and give it a positive karma point if it fixes it for you too?
Comment 6 Fedora Update System 2009-11-04 07:25:21 EST
mathgl-1.9-6.fc11.1, plplot-5.9.5-1.fc11, pfstools-1.7.0-8.fc11, GMT-4.5.0-4.fc11, octave-forge-20090607-15.fc11, octave-3.2.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.